Skip to content

ElementNodeElement

Canonical path: NemAll_Python_BasisElements.ElementNodeElement

Bases: BasisElement, AllplanElement

ElementNodeElement class

Methods:

  • GetObjectList

    Get the list of element node objects

  • GetParentID

    Get parent ID

  • SetParentID

    Set the parent element id to this object

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert the list to a string

GetObjectList

GetObjectList() -> list

Get the list of element node objects

Returns:

  • list

    Element node object list

GetParentID

GetParentID() -> type

Get parent ID

Returns:

  • type

    UUID

SetParentID

SetParentID(ParentID: type)

Set the parent element id to this object

Parameters:

  • ParentID (type) –

    (UUID) sub element id

__init__ overloaded

__init__()

Initialize

__init__(
    commonProp: CommonProperties,
    elementNodeId: type,
    elementNodeObjectList: list,
)

Constructor

Parameters:

  • commonProp (CommonProperties) –

    Common properties

  • elementGroupProp

    ElementGroup properties

  • elementGroupObjectList

    ElementGroup object list

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string