Skip to content

AttributeIntegerVec

Canonical path: NemAll_Python_BaseElements.AttributeIntegerVec

Bases: Attribute

IntegerVec attribute

Methods:

  • __eq__

    Equal operator

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __ne__

    Unequal operator

  • __repr__

    Convert to string

Attributes:

Value property writable

Value: list[int] | VecIntList

Get the attribute value

__eq__

__eq__(element: AttributeIntegerVec) -> bool

Equal operator

Parameters:

Returns:

  • bool

    Elements are equal: true/false

__init__ overloaded

__init__()

Initialize

__init__(id: int, value: list[int] | VecIntList)

Constructor

Parameters:

  • id (int) –

    Attribute id

  • value (list[int] | VecIntList) –

    Attribute value

__init__(element: AttributeIntegerVec)

Copy constructor

Parameters:

__ne__

__ne__(element: AttributeIntegerVec) -> bool

Unequal operator

Parameters:

Returns:

  • bool

    Elements are unequal: true/false

__repr__

__repr__() -> str

Convert to string