Skip to content

ClosedArea3D

Canonical path: NemAll_Python_Geometry.ClosedArea3D

3D closed area Representation class for 3D geometry area

Methods:

Attributes:

  • RefPlacement (None) –

    Get and set the reference placement 3d as property

RefPlacement property

RefPlacement: None

Get and set the reference placement 3d as property

:type: None

AddInnerCurve

AddInnerCurve(innerpath: Path2D) -> bool

Add new inner curve

Parameters:

  • innerpath (Path2D) –

    New inner curve ( Path2D )

Returns:

  • bool

    true if the operation was successful

Clear

Clear()

Clear all the components of this Profile

GetInnerCurve

GetInnerCurve(index: int) -> Path2D

Get the curve of given index

Parameters:

  • index (int) –

    Index of the inner curve

Returns:

  • Path2D

    const reference to the curve ( Path2D )

GetInnerList

GetInnerList() -> Path2DList

Get the list of the inner curves

Returns:

  • Path2DList

    reference to a vector that contains the inner curves ( Path2D )

GetOuterCurve

GetOuterCurve() -> Path2D

Get the outer curve of this profile

Returns:

  • Path2D

    const reference to outer curve ( Path2D )

GetRefPlacement

GetRefPlacement() -> AxisPlacement3D

Get axis placement

Returns:

InnerCount

InnerCount() -> int

Get the count of inner curves

Returns:

  • int

    count of inner curves

IsValid

IsValid() -> bool

Set Check the validity

Returns:

  • bool

    true if this Profile is valid

SetOuterCurve

SetOuterCurve(outerpath: Path2D)

Set new Outer curve ( bounds )

Parameters:

  • outerpath (Path2D) –

    New outer curve ( Path2D )

SetRefPlacement

SetRefPlacement(placement: AxisPlacement3D)

Set axis placement

Parameters:

__eq__

__eq__(closedArea: ClosedArea3D) -> object

Comparison of closedAreas without tolerance.

Be careful, this method work without tolerance!

Parameters:

Returns:

  • object

    True when closedAreas are equal, otherwise false.

__init__ overloaded

__init__()

Initialize

__init__(closedArea: ClosedArea3D)

Copy constructor.

Parameters:

  • closedArea (ClosedArea3D) –

    3D closed area which will be copied.

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string