Skip to content

BeamElement

Canonical path: NemAll_Python_ArchElements.BeamElement

Bases: ArchElement, AllplanElement

Representation of the upstand and lowstand beam

Methods:

Attributes:

Properties property writable

Properties: BeamProperties

Properties of the beam

GetProperties

GetProperties() -> BeamProperties

Get the beam properties

Returns:

SetProperties

SetProperties(beamProp: BeamProperties)

Set the beam properties

Parameters:

__init__ overloaded

__init__()

Initialize

__init__(beamProp: BeamProperties, axis: object)

Constructor

Parameters:

  • beamProp (BeamProperties) –

    Beam properties

  • axis (object) –

    Axis

__init__(element: BeamElement)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string