Skip to content

MacroProperties

Canonical path: NemAll_Python_BasisElements.MacroProperties

Properties of the macro definition

Methods:

  • __eq__

    equal operator

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert to string

Attributes:

CatalogName property writable

CatalogName: str

Get the Catalog name

DomainType property writable

DomainType: int

Get the Domain type

InsertionPoint property writable

InsertionPoint: Point3D

Macro reference point

IsScaleDependent property writable

IsScaleDependent: bool

Whether the macro should be scale dependent

Name property writable

Name: str

Get the Name

PositionNr property writable

PositionNr: int

Get the Position number

SubType property writable

SubType: int

Get the Sub type

UnitFactor property writable

UnitFactor: float

Get the Unit factor

__eq__

__eq__(prop: MacroProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__ overloaded

__init__()

Initialize

__init__(element: MacroProperties)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string