Skip to content

StructuralBraceProperties

Canonical path: NemAll_Python_ArchElements.StructuralBraceProperties

Bases: StructuralElementProperties, ArchBaseProperties

Representation of the properties of the structural framing bracing

Methods:

GetEndPoint

GetEndPoint() -> Point3D

Get the end point of the element in world coordinate system

Returns:

GetStartPoint

GetStartPoint() -> Point3D

Get the start point of the element in world coordinate system

Returns:

SetAnchorPointProperties

SetAnchorPointProperties(
    anchorPointStart: int,
    offsetStart: Point2D,
    anchorPointEnd: int,
    offsetEnd: Point2D,
    twoAnchorPoints: bool,
)

Set the Column Anchor Point Properties

Values for anchor point

1 - LeftBottom 2 - RightBottom 3 - RightTop 4 - LeftTop 5 - Center 6 - MiddleBottom 7 - MiddleRight 8 - MiddleTop 9 - MiddleLeft

10 - CenterOfGravity

Parameters:

  • anchorPointStart (int) –

    Anchor point position

  • offsetStart (Point2D) –

    Offset from start anchor point

  • anchorPointEnd (int) –

    Anchor point position

  • offsetEnd (Point2D) –

    Offset from end anchor point

  • twoAnchorPoints (bool) –

    true when both anchor points are used

SetEndPoint

SetEndPoint(x: float, y: float, z: float)

Set the end point of the element in world coordinate system

Parameters:

  • x (float) –

    x coordinate

  • y (float) –

    y coordinate

  • z (float) –

    z coordinate

SetHeightProperties

SetHeightProperties(doc: DocumentAdapter, planeReferences: BasePlaneReferences)

Set height properties

Parameters:

SetHeightPropsByPlacementPoints

SetHeightPropsByPlacementPoints(
    doc: DocumentAdapter,
    value: BasePlaneReferences,
    startPointZcoord: float,
    endPointZcoord: float,
)

Set HeightProperties by the placement points

Parameters:

  • doc (DocumentAdapter) –

    Document

  • value (BasePlaneReferences) –

    Height properties

  • startPointZcoord (float) –

    Z coordinate of the start point

  • endPointZcoord (float) –

    Z coordinate of the end point

SetStartPoint

SetStartPoint(x: float, y: float, z: float)

Set the start point of the element in world coordinate system

Parameters:

  • x (float) –

    x coordinate

  • y (float) –

    y coordinate

  • z (float) –

    z coordinate

__init__ overloaded

__init__()

Initialize

__init__(value: StructuralBraceProperties)

Constructor

Parameters: