Skip to content

BendingShape

Canonical path: NemAll_Python_Reinforcement.BendingShape

Implementation of the reinforcement shape

Methods:

Attributes:

BendingRoller property writable

BendingRoller: list[float]

Get the bending roller

HookLengthEnd property writable

HookLengthEnd: float

Get the hook length a the end of the shape

HookLengthStart property writable

HookLengthStart: float

Get the hook length a the start of the shape

ShapePolyline property writable

ShapePolyline: Polyline3D

Get the shape polyline

GetBendingRoller

GetBendingRoller() -> VecDoubleList

Get the bending roller

Returns:

GetBendingShapeType

GetBendingShapeType() -> BendingShapeType

Get the bending shape type

Returns:

GetConcreteGrade

GetConcreteGrade() -> int

Get the concrete grade

Returns:

  • int

    Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)

GetDiameter

GetDiameter() -> float

Get the diameter

Returns:

  • float

    Diameter

GetHookAngleEnd

GetHookAngleEnd() -> float

Get the hook angle a the end of the shape

Returns:

  • float

    Hook angle at the end of the shape

GetHookAngleStart

GetHookAngleStart() -> float

Get the hook angle a the start of the shape

Returns:

  • float

    Hook angle at the start of the shape

GetHookLengthEnd

GetHookLengthEnd() -> float

Get the hook length a the end of the shape

Returns:

  • float

    Hook length at the end of the shape

GetHookLengthStart

GetHookLengthStart() -> float

Get the hook length a the start of the shape

Returns:

  • float

    Hook length at the start of the shape

GetHookTypeEnd

GetHookTypeEnd() -> HookType

Get the hook type a the end of the shape

Returns:

  • HookType

    Hook type a the end of the shape

GetHookTypeStart

GetHookTypeStart() -> HookType

Get the hook type a the start of the shape

Returns:

  • HookType

    Hook type a the start of the shape

GetMeshBendingDirection

GetMeshBendingDirection() -> MeshBendingDirection

Get the mesh bending direction

Returns:

GetMeshType

GetMeshType() -> str

Get the mesh type

Returns:

  • str

    Mesh type

GetShapePolyline

GetShapePolyline() -> Polyline3D

Get the shape polyline

Returns:

GetSteelGrade

GetSteelGrade() -> int

Get the steel grade

Returns:

  • int

    Steel grade

IsValid

IsValid() -> bool

Get the state of the shape

Returns:

  • bool

    Shape is valid: true/false

Move

Move(transVec: Vector3D)

Move the shape

Parameters:

Rotate overloaded

Rotate(modelAngles: object, refPnt: Point3D)

Rotate the shape

Parameters:

  • modelAngles (object) –

    Model angles

  • refPnt (Point3D) –

    Reference point of the rotation

Rotate(modelAngles: object)

Rotate the shape

Parameters:

  • modelAngles (object) –

    Model angles

SetBendingRoller

SetBendingRoller(bendingRoller: VecDoubleList)

Set the bending roller

Parameters:

SetHookLengthEnd

SetHookLengthEnd(hookLengthEnd: float)

Set the end length of the hook

Parameters:

  • hookLengthEnd (float) –

    End length of the hook

SetHookLengthStart

SetHookLengthStart(hookLengthStart: float)

Set the start length of the hook

Parameters:

  • hookLengthStart (float) –

    Start length of the hook

SetShapePolyline

SetShapePolyline(shapePol: Polyline3D)

Set the shape polyline

Parameters:

Transform

Transform(transMat: Matrix3D)

Transform the shape

Parameters:

  • transMat (Matrix3D) –

    Transformation matrix

__eq__

__eq__(shape: BendingShape) -> bool

Compare operator

Parameters:

Returns:

  • bool

    Shapes are equal: true/false

__init__ overloaded

__init__()

Initialize

__init__(
    shapePol: Polyline3D,
    bendingRoller: VecDoubleList,
    diameter: float,
    steelGrade: int,
    concreteGrade: int,
    bendingShapeType: BendingShapeType,
)

Constructor

Parameters:

  • shapePol (Polyline3D) –

    Shape polyline

  • bendingRoller (VecDoubleList) –

    Bending roller

  • diameter (float) –

    Diameter

  • steelGrade (int) –

    Steel grade

  • concreteGrade (int) –

    Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)

  • bendingShapeType (BendingShapeType) –

    Bending shape type

__init__(
    shapePoint: Point3D, diameter: float, steelGrade: int, concreteGrade: int
)

Constructor for a point placement

Parameters:

  • shapePoint (Point3D) –

    Shape placement point

  • diameter (float) –

    Diameter

  • steelGrade (int) –

    Steel grade

  • concreteGrade (int) –

    Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)

__init__(
    shapePol: Polyline3D,
    bendingRoller: VecDoubleList,
    meshType: str,
    meshBendingDirection: MeshBendingDirection,
    steelGrade: int,
    concreteGrade: int,
    bendingShapeType: BendingShapeType,
)

Constructor

Parameters:

  • shapePol (Polyline3D) –

    Shape polyline

  • bendingRoller (VecDoubleList) –

    Bending roller

  • meshType (str) –

    Mesh type

  • meshBendingDirection (MeshBendingDirection) –

    Mesh bending direction

  • steelGrade (int) –

    Steel grade

  • concreteGrade (int) –

    Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)

  • bendingShapeType (BendingShapeType) –

    Bending shape type

__init__(
    shapePol: Polyline3D,
    bendingRoller: VecDoubleList,
    diameter: float,
    steelGrade: int,
    concreteGrade: int,
    bendingShapeType: BendingShapeType,
    hookLengthStart: float,
    hookAngleStart: float,
    hookTypeStart: HookType,
    hookLengthEnd: float,
    hookAngleEnd: float,
    hookTypeEnd: HookType,
)

Constructor

Parameters:

  • shapePol (Polyline3D) –

    Shape polyline

  • bendingRoller (VecDoubleList) –

    Bending roller

  • diameter (float) –

    Diameter

  • steelGrade (int) –

    Steel grade

  • concreteGrade (int) –

    Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)

  • bendingShapeType (BendingShapeType) –

    Bending shape type

  • hookLengthStart (float) –

    Hook length at the start of the shape

  • hookAngleStart (float) –

    Hook angle at the start of the shape

  • hookTypeStart (HookType) –

    Hook type at the start of the shape

  • hookLengthEnd (float) –

    Hook length at the end of the shape

  • hookAngleEnd (float) –

    Hook angle at the end of the shape

  • hookTypeEnd (HookType) –

    Hook type at the end of the shape

__init__(
    shapePol: Polyline3D,
    bendingRoller: VecDoubleList,
    meshType: str,
    meshBendingDirection: MeshBendingDirection,
    steelGrade: int,
    concreteGrade: int,
    bendingShapeType: BendingShapeType,
    hookLengthStart: float,
    hookAngleStart: float,
    hookTypeStart: HookType,
    hookLengthEnd: float,
    hookAngleEnd: float,
    hookTypeEnd: HookType,
)

Constructor

Parameters:

  • shapePol (Polyline3D) –

    Shape polyline

  • bendingRoller (VecDoubleList) –

    Bending roller

  • meshType (str) –

    Mesh type

  • meshBendingDirection (MeshBendingDirection) –

    Mesh bending direction

  • steelGrade (int) –

    Steel grade

  • concreteGrade (int) –

    Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)

  • bendingShapeType (BendingShapeType) –

    Bending shape type

  • hookLengthStart (float) –

    Hook length at the start of the shape

  • hookAngleStart (float) –

    Hook angle at the start of the shape

  • hookTypeStart (HookType) –

    Hook type at the start of the shape

  • hookLengthEnd (float) –

    Hook length at the end of the shape

  • hookAngleEnd (float) –

    Hook angle at the end of the shape

  • hookTypeEnd (HookType) –

    Hook type at the end of the shape

__init__(element: BendingShape)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string