Skip to content

ViewSectionElement

Canonical path: NemAll_Python_BasisElements.ViewSectionElement

Bases: AllplanElement

Representation of a Unified View and Section (UVS) in Allplan

Methods:

Attributes:

DimensionElements property writable

DimensionElements: list

Dimension elements

GeneralSectionProperties property writable

GeneralSectionProperties: SectionGeneralProperties

General section properties

ReinforcementLabels property writable

ReinforcementLabels: ReinforcementLabel

Reinforcement labels

SectionDefinitionData property writable

SectionDefinitionData: SectionDefinitionData

Section definition data

TextElements property writable

TextElements: list

Labels

ViewMatrix property writable

ViewMatrix: Matrix3D

View transformation matrix

CreateSectionBody

CreateSectionBody(
    doc: DocumentAdapter,
    insertionMat: Matrix3D,
    undoRedoService: object | None = None,
)

Create the section body

Parameters:

DrawElement

DrawElement(
    modelElements: object,
    insertionMat: Matrix3D,
    docID: int,
    asStaticPreview: bool,
) -> MinMax3D

Draw eLement preview in Allplan

Parameters:

  • modelElements (object) –

    Python object which should be drawn

  • insertionMat (Matrix3D) –

    insertion matrix

  • docID (int) –

    Document ID

Returns:

  • MinMax3D

    Min/max box of the preview

__init__ overloaded

__init__()

Initialize

__init__(param: ViewSectionElement)

Args: param

__repr__

__repr__() -> str

Convert to string