Skip to content

SectionDefinitionProperties

Canonical path: NemAll_Python_BasisElements.SectionDefinitionProperties

Section definition properties

Classes:

Methods:

Attributes:

ClippingPathProperties property

ClippingPathProperties: None

Set/Get the clipping path properties

:type: None

IsAdvancedOn property

IsAdvancedOn: None

Property for type of section architecture= OFF /Engineering = ON

:type: None

IsSectionBodyOn property

IsSectionBodyOn: None

Property for show the section body

:type: None

RefMode property

RefMode: None

Property for the reference mode

:type: None

ViewInputType property

ViewInputType: None

Property for the view input type

:type: None

RefMode_Enum

Canonical path: NemAll_Python_BasisElements.SectionDefinitionProperties.RefMode_Enum

Bases: Enum

View input type

Methods:

__getitem__

__getitem__(key: str | int | float) -> RefMode_Enum

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

ViewInputType_Enum

Canonical path: NemAll_Python_BasisElements.SectionDefinitionProperties.ViewInputType_Enum

Bases: Enum

View input type

Methods:

__getitem__

__getitem__(key: str | int | float) -> ViewInputType_Enum

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

__init__

__init__()

Initialize