Skip to content

GUID

Canonical path: NemAll_Python_Utility.GUID

Methods:

FromString staticmethod

FromString(strGuid: str) -> GUID

Create a GUID from a string

Parameters:

  • strGuid (str) –

    GUID as string

Returns:

  • GUID

    GUID from the string

__eq__

__eq__(compGuid: GUID) -> bool

Compare a GUID

Parameters:

  • compGuid (GUID) –

    GUID to compare

Returns:

  • bool

    GUIDs are equal: True/False

__hash__

__hash__() -> int

Create a hash from the GUID

Returns:

  • int

    hash from the GUID

__init__

__init__()

Initialize

__repr__

__repr__() -> str

Create a string from the GUID

Returns:

  • str

    string from the GUID