Skip to content

eIdentificationMode

Canonical path: NemAll_Python_IFW_Input.eIdentificationMode

Bases: Enum

Type of the identification mode during point input.

This class defines possible options for point or/and element identification. In other words, for what kind of points or geometry elements should the IFW search for during a point input.

Attributes:

eIDENT_ARCHPOINT class-attribute instance-attribute

eIDENT_ARCHPOINT = 10

Identify the nearest point at the cursor position.

Similar to eIDENT_POINT, but additionally when point was found on an architectural element, a reference 2D line, on which this point is located, is identified. The line can be get with GetReferenceLine.

eIDENT_ARCHPOINT_OFFSET class-attribute instance-attribute

eIDENT_ARCHPOINT_OFFSET = 11

Identify the nearest point at the cursor position.

As eIDENT_ARCHPOINT, but in case a line is identified, a second input step is activated similar to the in eIDENT_POINT_OFFSET

When the point was found in an UVS, the point is returned in the world coordinate system

eIDENT_ARCH_ELEMENTPOINT class-attribute instance-attribute

eIDENT_ARCH_ELEMENTPOINT = 12

Identify the nearest element point at an architecture element.

Similar to eIDENT_ELEMENTPOINT, but additionally a reference line of an architectural element is identified and can be get with GetReferenceLine

eIDENT_DOCKINGPOINT class-attribute instance-attribute

eIDENT_DOCKINGPOINT = 13

Identify the nearest docking point at the cursor position

eIDENT_ELEMENTPOINT class-attribute instance-attribute

eIDENT_ELEMENTPOINT = 1

Identify the nearest element point at the cursor position.

Similar to eIDENT_POINT, but input controls for XYZ coordinates are disabled and track tracing is not performed. This implies, that the input point lies on an existing element.

eIDENT_POINT class-attribute instance-attribute

eIDENT_POINT = 0

Identify the nearest point at the cursor position.

Identified are start, end, center or intersection points of all kind of elements. Snapping options set by the user in Allplan settings are considered. This is the default way of point identification.

eIDENT_POINT_ASSOC_VIEW_WORLD class-attribute instance-attribute

eIDENT_POINT_ASSOC_VIEW_WORLD = 2

Identify the nearest point at the cursor position.

Similar to eIDENT_POINT, but when the point was found in an UVS, the point is returned in the world coordinate system

eIDENT_POINT_ELEMENT class-attribute instance-attribute

eIDENT_POINT_ELEMENT = 3

Identify the nearest point or element at the cursor position

As eIDENT_POINT, but additionally a geometry element (like edge/face of a polyhedron, polygon segment, etc...) is searched during the point input. The found geometry element can be get with GetSelectedGeometryElement. Element is not identified, when a point (start, end, center, intersection, etc...) is found.

Filter for the element identification can be set with SetGeometryFilter and SetGeometryElementFilter

eIDENT_POINT_ELEMENT_ALWAYS class-attribute instance-attribute

eIDENT_POINT_ELEMENT_ALWAYS = 5

Similar to eIDENT_POINT_ELEMENT, but the element is always identified, even when a point was found

eIDENT_POINT_ELEMENT_ALWAYS_CENTER class-attribute instance-attribute

eIDENT_POINT_ELEMENT_ALWAYS_CENTER = 6

As eIDENT_POINT_ELEMENT_ALWAYS

eIDENT_POINT_ELEMENT_CENTER class-attribute instance-attribute

eIDENT_POINT_ELEMENT_CENTER = 4

Similar to eIDENT_POINT_ELEMENT, but the element is identified also, when a center point (but not start/end point) is found.

eIDENT_POINT_OFFSET class-attribute instance-attribute

eIDENT_POINT_OFFSET = 8

Identify the nearest point or element at the cursor position Similar to POINT_ELEMENT, but in case a line is identified (2D or 3D), a second input step is introduced, where the user can provide the offset distance. The resulting point will be located on the line at the given distance from the start or end point (depending, where the line was clicked)

eIDENT_POINT_PERPENDICULAR class-attribute instance-attribute

eIDENT_POINT_PERPENDICULAR = 7

Identify the nearest point or point perpendicular to a line

Similar to eIDENT_POINT, but additionally if a 2D line is identified, the result will be a point calculated by projecting the previously input point onto this line.

Works only in ground view!

eIDENT_TEXTPOINT class-attribute instance-attribute

eIDENT_TEXTPOINT = 9

Snapping only to the anchor points of text or label elements

eIDENT_TEXTPOINTER_POINT class-attribute instance-attribute

eIDENT_TEXTPOINTER_POINT = 14