Skip to content

PrecastElement

Canonical path: NemAll_Python_Precast.PrecastElement

Bases: AllplanElement

Methods:

Attributes:

  • Properties (None) –

    Property for Precast Element Properties

  • deletePython (None) –

    Property to delete Python after elementation

Properties property

Properties: None

Property for Precast Element Properties Value type: PrecastElementProperties

:type: None

deletePython property

deletePython: None

Property to delete Python after elementation Value type: int

:type: None

__init__

__init__(Properties: PrecastElementProperties)

Constructor

Parameters:

  • elementProp

    Element properties

__repr__

__repr__() -> str

Convert to string