Skip to content

SectionAlongPathLabelingStripSetting

Canonical path: NemAll_Python_BasisElements.SectionAlongPathLabelingStripSetting

Labeling strip settings

Methods:

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

Attributes:

Distance_1 property writable

Distance_1: float

Get the Distance 1 in mm

Distance_2 property writable

Distance_2: float

Get the Distance 2 in mm

Distance_3 property writable

Distance_3: float

Get the Distance 3 in mm

Distance_4 property writable

Distance_4: float

Get the Distance 4 in mm

Distance_5 property writable

Distance_5: float

Get the Distance 5 in mm

Distance_6 property writable

Distance_6: float

Get the Distance 6 in mm

Distance_7 property writable

Distance_7: float

Get the Distance 7 in mm

HeightLines_Color property writable

HeightLines_Color: int

Get the Height lines color

HeightLines_HeightZone property writable

HeightLines_HeightZone: int

Get the Height lines height zone

HeightLines_LineType property writable

HeightLines_LineType: int

Get the Height lines line type

HeightLines_Pen property writable

HeightLines_Pen: int

Get the Height lines pen

HeightLines_ProfileZone property writable

HeightLines_ProfileZone: int

Get the Height lines profile zone

HeightLines_Splay property writable

HeightLines_Splay: int

Get the Height lines splay

HeightLines_StationZone property writable

HeightLines_StationZone: int

Get the Height lines station zone

HeightText_Color property writable

HeightText_Color: int

Get the Height text color

HeightText_Distance property writable

HeightText_Distance: float

Get the Height text distance in mm

HeightText_Height property writable

HeightText_Height: float

Get the Height text height in mm

HeightText_Pen property writable

HeightText_Pen: int

Get the Height text pen

HeightText_Precision property writable

HeightText_Precision: int

Get the Height text decimals

HeightText_Width property writable

HeightText_Width: float

Get the Height text width in mm

ProfileAx_Color property writable

ProfileAx_Color: int

Get the Profile axis color

ProfileAx_LineType property writable

ProfileAx_LineType: int

Get the Profile axis line type

ProfileAx_Pen property writable

ProfileAx_Pen: int

Get the Profile axis pen

ProfileFrame_Color property writable

ProfileFrame_Color: int

Get the Profile frame color

ProfileFrame_LineType property writable

ProfileFrame_LineType: int

Get the Profile frame line type

ProfileFrame_Pen property writable

ProfileFrame_Pen: int

Get the Profile frame pen

ProfileLine_Color property writable

ProfileLine_Color: int

Get the Profile line color

ProfileLine_LineType property writable

ProfileLine_LineType: int

Get the Profile line line type

ProfileLine_Muster property writable

ProfileLine_Muster: int

Get the Profile line pattern

ProfileLine_Pen property writable

ProfileLine_Pen: int

Get the Profile line pen

RefererenzeHeight_Distance property writable

RefererenzeHeight_Distance: float

Get the Reference height text distance in mm

RefererenzeHeight_Height property writable

RefererenzeHeight_Height: float

Get the Reference height text height in mm

RefererenzeHeight_TextColor property writable

RefererenzeHeight_TextColor: int

Get the Reference height text color

RefererenzeHeight_TextPen property writable

RefererenzeHeight_TextPen: int

Get the Reference height text pen

RefererenzeHeight_TextPrecision property writable

RefererenzeHeight_TextPrecision: int

Get the Reference height text decimals

RefererenzeHeight_Width property writable

RefererenzeHeight_Width: float

Get the Reference height text width in mm

StationText_Color property writable

StationText_Color: int

Get the Station text color

StationText_Distance property writable

StationText_Distance: float

Get the Station text distance in mm

StationText_Height property writable

StationText_Height: float

Get the Station text height in mm

StationText_Pen property writable

StationText_Pen: int

Get the Station text pen

StationText_Precision property writable

StationText_Precision: int

Get the Station text decimals

StationText_Width property writable

StationText_Width: float

Get the Station text width in mm

__init__ overloaded

__init__(bInitFromSTW: bool = False)

constructor

Parameters:

  • bInitFromSTW (bool, default: False ) –
    • is structure initialized from standard values

copy constructor

Parameters: