Skip to content

WallTierProperties

Canonical path: NemAll_Python_ArchElements.WallTierProperties

Bases: ArchBaseProperties

Representation of the properties of a single layer of a multi layer wall

Methods:

Attributes:

Thickness property writable

Thickness: float

Tier thickness

GetThickness

GetThickness() -> float

Get the wall layer thickness

Returns:

  • float

    Thickness

SetThickness

SetThickness(thickness: float)

Set the wall layer thickness

Parameters:

  • thickness (float) –

    Thickness

__init__

__init__(tierProp: WallTierProperties)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string