Skip to content

BaseElementAdapterList

Canonical path: NemAll_Python_IFW_ElementAdapter.BaseElementAdapterList

Implementation of the base element adapter list

The BaseElementAdapterList is a general container for the BaseElementAdapter

Methods:

  • __getitem__

    Get the item for the index

  • __iadd__

    Add elements to the list

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __iter__

    Get the iterator

  • __len__

    Get the length of the list

  • __repr__

    Get a string from the list items

  • append

    Append an element

  • clear

    Clear the list

__getitem__

__getitem__(index: int) -> BaseElementAdapter

Get the item for the index

__iadd__

Add elements to the list

Parameters:

__init__ overloaded

__init__()

Initialize

__init__(elements: List[BaseElementAdapter])

Constructor

Parameters:

__init__(eleList: BaseElementAdapterList)

Copy constructor

Parameters:

__iter__

__iter__() -> Iterator[BaseElementAdapter]

Get the iterator

__len__

__len__() -> int

Get the length of the list

Returns:

  • int

    Length of the list

__repr__

__repr__() -> str

Get a string from the list items

append

append(element: BaseElementAdapter)

Append an element

Parameters:

clear

clear()

Clear the list