Skip to content

ArchBaseProperties

Canonical path: NemAll_Python_ArchElements.ArchBaseProperties

Base class representing properties of all kinds of architectural components

Methods:

Attributes:

BackgroundColor property writable

BackgroundColor: int

Get the background color

BitmapName property writable

BitmapName: str

Get the name of the bitmap

CalculationMode property writable

CalculationMode: int

Calculation mode, represented by an integer as follows:

  • 0: m3
  • 1: m2
  • 2: m
  • 3: Pcs
  • 4: kg

CircleDivision property writable

CircleDivision: float

Number the circle segments in case of a circular cross section

CommonProperties property writable

CommonProperties: CommonProperties

Get the common properties

FaceStyle property writable

FaceStyle: int

Get the face style ID

Factor property writable

Factor: float

Get the factor

Filling property writable

Filling: int

Get the filling ID

Hatch property writable

Hatch: int

Get the hatch ID

Material property writable

Material: str

Get the material

Name property writable

Name: str

Get the name

Pattern property writable

Pattern: int

Get the pattern ID

PlaneReferences property writable

PlaneReferences: PlaneReferences

Get the plane references

Priority property writable

Priority: int

Get the priority

Surface property writable

Surface: str

Get the surface name and path

Trade property writable

Trade: int

Trade index according to the definition of the enumeration attribute trade (@209@)

GetAreaPresentationID

GetAreaPresentationID() -> int

Get the ID of the area representation

Returns:

  • int

    ID of the area representation

GetAreaPresentationType

GetAreaPresentationType() -> int

Get the type of the area representation

Returns:

  • int

    Type of the area representation

GetBackgroundColor

GetBackgroundColor() -> int

Get the background color

Returns:

  • int

    Background color

GetBitmapName

GetBitmapName() -> str

Get the name of the bitmap

Returns:

  • str

    Name of the bitmap

GetCalculationMode

GetCalculationMode() -> int

Get the calculation mode

Returns:

  • int

    Integer representing the calculation mode as follows:

    • 0: m3
    • 1: m2
    • 2: m
    • 3: Pcs
    • 4: kg

GetCircleDivision

GetCircleDivision() -> int

Get the circle division (relevant only for circular profiles))

Returns:

  • int

    Number of circle segments

GetCommonProperties

GetCommonProperties() -> CommonProperties

Get the common properties

Returns:

GetFaceStyle

GetFaceStyle() -> int

Get the face style ID

Returns:

  • int

    Face style ID

GetFactor

GetFactor() -> float

Get the factor

Returns:

  • float

    Factor

GetFilling

GetFilling() -> int

Get the filling ID

Returns:

  • int

    Filling ID

GetHatch

GetHatch() -> int

Get the hatch ID

Returns:

  • int

    Hatch ID

GetMaterial

GetMaterial() -> str

Get the material

Returns:

  • str

    Material

GetName

GetName() -> str

Get the name

Returns:

  • str

    Name

GetPattern

GetPattern() -> int

Get the pattern ID

Returns:

  • int

    Pattern ID

GetPlaneReferences

GetPlaneReferences() -> PlaneReferences

Get the plane references

Returns:

GetPriority

GetPriority() -> int

Get the priority

Returns:

  • int

    Priority

GetSurface

GetSurface() -> str

Get the surface name and path

Returns:

  • str

    Surface name and path

GetTrade

GetTrade() -> int

Get the trade index

Returns:

  • int

    Trade index according to the definition of the enumeration attribute trade (@209@)

IsShowAreaElementInGroundView

IsShowAreaElementInGroundView() -> bool

Get the 'Show the area element in the ground view' state

Returns:

  • bool

    Show the area element in the ground view: true/false

LoadFromFavoriteFile

LoadFromFavoriteFile(doc: DocumentAdapter)

Load the properties from the favorite file

Parameters:

RemoveCommonProperties

RemoveCommonProperties()

Remove the common properties

ResetAreaElement

ResetAreaElement()

Reset the area element

ResetBackgroundColor

ResetBackgroundColor()

Reset the background color

SetBackgroundColor

SetBackgroundColor(colorID: int)

Set the background color

Parameters:

  • colorID (int) –

    Background color ID

SetBitmapName

SetBitmapName(bitmapName: str)

Set the name of the bitmap

Parameters:

  • bitmapName (str) –

    Bitmap name

SetCalculationMode

SetCalculationMode(calculationMode: int)

Set the calculation mode

Parameters:

  • calculationMode (int) –

    Calculation mode

SetCircleDivision

SetCircleDivision(circleDivision: int)

Set the circle division

Parameters:

  • circleDivision (int) –

    Circle division

SetCommonProperties

SetCommonProperties(comProp: CommonProperties)

Set the common properties

Parameters:

SetFaceStyle

SetFaceStyle(faceStyleID: int)

Set the face style

Parameters:

  • faceStyleID (int) –

    Face style ID

SetFactor

SetFactor(factor: float)

Set the factor

Parameters:

  • factor (float) –

    Factor

SetFilling

SetFilling(fillingID: int)

Set the filling

Parameters:

  • fillingID (int) –

    Filling ID

SetHatch

SetHatch(hatchID: int)

Set the hatch

Parameters:

  • hatchID (int) –

    Hatch ID

SetMaterial

SetMaterial(material: str)

Set the material

Parameters:

  • material (str) –

    Material

SetName

SetName(name: str)

Set the name

Parameters:

  • name (str) –

    Name

SetPattern

SetPattern(patternID: int)

Set the pattern

Parameters:

  • patternID (int) –

    Pattern ID

SetPlaneReferences

SetPlaneReferences(planeRef: PlaneReferences)

Set the plane references

Parameters:

SetPriority

SetPriority(priority: int)

Set the priority

Parameters:

  • priority (int) –

    Priority

SetShowAreaElementInGroundView

SetShowAreaElementInGroundView(showInGroundView: bool)

Set the show area element in ground view state

Parameters:

  • showInGroundView (bool) –

    Show the area element in the ground view

SetSurface

SetSurface(surface: str)

Set the surface

Parameters:

  • surface (str) –

    Surface

SetTrade

SetTrade(value: int)

Set the trade index

Parameters:

  • value (int) –

    Trade index according to the definition of the enumeration attribute trade (@209@)

__init__

__init__(element: ArchBaseProperties)

Copy constructor

Parameters: