Skip to content

AttributeEnum

Canonical path: NemAll_Python_BaseElements.AttributeEnum

Bases: Attribute

Enum attribute

Methods:

  • __eq__

    Equal operator

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __ne__

    Unequal operator

  • __repr__

    Convert to string

Attributes:

  • Value (int) –

    Get the attribute value

Value property writable

Value: int

Get the attribute value

__eq__

__eq__(element: AttributeEnum) -> bool

Equal operator

Parameters:

Returns:

  • bool

    Elements are equal: true/false

__init__ overloaded

__init__()

Initialize

__init__(id: int, value: int)

Constructor

Parameters:

  • id (int) –

    Attribute id

  • value (int) –

    Attribute value

__init__(element: AttributeEnum)

Copy constructor

Parameters:

__ne__

__ne__(element: AttributeEnum) -> bool

Unequal operator

Parameters:

Returns:

  • bool

    Elements are unequal: true/false

__repr__

__repr__() -> str

Convert to string