Skip to content

ValueInputControlData

Canonical path: NemAll_Python_IFW_Input.ValueInputControlData

Data class with settings of the input control, that can be optionally displayed in the dialog line e.g. along with the XYZ coordinate input fields.

Methods:

AddShortcutControl

AddShortcutControl(ctrlType: eValueInputControlType)

Add a shortcut control to the coordinate input dialog

Parameters:

GetControlType

GetControlType() -> eValueInputControlType

Get the type of the input control

Returns:

GetInitText

GetInitText() -> object

Get the init input text

Returns:

  • object

    Init input text

GetInitValue

GetInitValue() -> float

Get the init input value

Returns:

  • float

    Init input value

GetMaxTextLen

GetMaxTextLen() -> int

Get the maximal length of the input text

Returns:

  • int

    Maximal length of the input text

GetMaxValue

GetMaxValue() -> float

Get the maximal input value

Returns:

  • float

    Maximal input value

GetMinTextLen

GetMinTextLen() -> int

Get the minimal length of the input text

Returns:

  • int

    Minimal length of the input text

GetMinValue

GetMinValue() -> float

Get the minimal input value

Returns:

  • float

    Minimal input value

GetShortcutControlType

GetShortcutControlType() -> eValueInputControlType

Get the type of the shortcut input control

Returns:

IsDisableCoord

IsDisableCoord() -> bool

Get the disable coordinate input state

Returns:

  • bool

    Disable the coordinate input in case of value input: true/false

IsEmptyControl

IsEmptyControl() -> bool

Get the empty input control state

Returns:

  • bool

    Set an empty value to the input control: true/false

IsSetFocus

IsSetFocus() -> bool

Get the input focus state

Returns:

  • bool

    Set the input focus to the control: true/false

__init__ overloaded

__init__()

Initialize

__init__(
    ctrlType: eValueInputControlType,
    bSetFocus: bool = True,
    bDisableCoord: bool = True,
)

Constructor to create a control with standard behavior defined by the control type

Parameters:

  • ctrlType (eValueInputControlType) –

    Control type

  • bSetFocus (bool, default: True ) –

    Set the input focus to the control: true/false

  • bDisableCoord (bool, default: True ) –

    Input inside the external control disables the coordinate controls: true/false

__init__(
    ctrlType: eValueInputControlType,
    minValue: float,
    maxValue: float,
    bSetFocus: bool,
    bDisableCoord: bool,
)

Constructor to create an empty control

Parameters:

  • ctrlType (eValueInputControlType) –

    Control type

  • minValue (float) –

    Minimal input value

  • maxValue (float) –

    Maximal input value

  • bSetFocus (bool) –

    Set the input focus to the control: true/false

  • bDisableCoord (bool) –

    Input inside the external control disables the coordinate controls: true/false

__init__(
    ctrlType: eValueInputControlType,
    minValue: int,
    maxValue: int,
    bSetFocus: bool,
    bDisableCoord: bool,
)

Constructor to create an empty control

Parameters:

  • ctrlType (eValueInputControlType) –

    Control type

  • minValue (int) –

    Minimal input value

  • maxValue (int) –

    Maximal input value

  • bSetFocus (bool) –

    Set the input focus to the control: true/false

  • bDisableCoord (bool) –

    Input inside the external control disables the coordinate controls: true/false

__init__(
    ctrlType: eValueInputControlType,
    initValue: float,
    minValue: float,
    maxValue: float,
    bSetFocus: bool,
    bDisableCoord: bool,
)

Constructor to create a control with an init value

Parameters:

  • ctrlType (eValueInputControlType) –

    Control type

  • initValue (float) –

    Initialize input value

  • minValue (float) –

    Minimal input value

  • maxValue (float) –

    Maximal input value

  • bSetFocus (bool) –

    Set the input focus to the control: true/false

  • bDisableCoord (bool) –

    Input inside the external control disables the coordinate controls: true/false

__init__(
    ctrlType: eValueInputControlType,
    initValue: int,
    minValue: int,
    maxValue: int,
    bSetFocus: bool,
    bDisableCoord: bool,
)

Constructor to create a control with an init value

Parameters:

  • ctrlType (eValueInputControlType) –

    Control type

  • initValue (int) –

    Initialize input value

  • minValue (int) –

    Minimal input value

  • maxValue (int) –

    Maximal input value

  • bSetFocus (bool) –

    Set the input focus to the control: true/false

  • bDisableCoord (bool) –

    Input inside the external control disables the coordinate controls: true/false

__init__(
    ctrlType: eValueInputControlType,
    initValue: float,
    bSetFocus: bool,
    bDisableCoord: bool,
)

Constructor to create a control with an init value. The value range is defined by the control type

Parameters:

  • ctrlType (eValueInputControlType) –

    Control type

  • initValue (float) –

    Initialize input value

  • bSetFocus (bool) –

    Set the input focus to the control: true/false

  • bDisableCoord (bool) –

    Input inside the external control disables the coordinate controls: true/false

__init__(
    ctrlType: eValueInputControlType,
    initText: object,
    minTextLen: int,
    maxTextLen: int,
    bSetFocus: bool = True,
    bDisableCoord: bool = False,
)

Constructor to create a control with an init text

Parameters:

  • ctrlType (eValueInputControlType) –

    Control type

  • initText (object) –

    Initialize input text

  • minTextLen (int) –

    Minimal text length

  • maxTextLen (int) –

    Maximal text length

  • bSetFocus (bool, default: True ) –

    Set the input focus to the control: true/false

  • bDisableCoord (bool, default: False ) –

    Input inside the external control disables the coordinate controls: true/false

__init__(element: ValueInputControlData)

Copy constructor

Parameters: