Skip to content

MinMax3D

Canonical path: NemAll_Python_Geometry.MinMax3D

Representation class for 3D MinMax box.

Methods:

  • Deflate

    dummy, is only needed for the creation of the documentation by MkDocs

  • Get

    Get minimum and maximum point

  • GetCenter

    Get box center point

  • GetMax

    Get maximum point

  • GetMin

    Get minimum point

  • GetSizeX

    Get the size of the box in the X direction

  • GetSizeY

    Get the size of the box in the Y direction

  • GetSizeZ

    Get the size of the box in the Y direction

  • Inflate

    dummy, is only needed for the creation of the documentation by MkDocs

  • IsContaining

    Is box inside this box

  • IsValid

    Test if box is valid

  • Overlaps

    Does box overlap this box

  • Reset

    Set min point to [DBL_MAX,DBL_MAX,DBL_MAX]

  • Set

    Set minimum and maximum point

  • SetMax

    Set maximum point

  • SetMin

    Set minimum point

  • __add__

    Expand MinMax3D box.

  • __eq__

    Comparison of minmax objects without tolerance.

  • __iadd__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert to string

Attributes:

  • Max (Point3D) –

    Get maximum point

  • Min (Point3D) –

    Get minimum point

  • SizeX (float) –

    Get the size of the box in the X direction

  • SizeY (float) –

    Get the size of the box in the Y direction

  • SizeZ (float) –

    Get the size of the box in the Y direction

Max property writable

Max: Point3D

Get maximum point

Min property writable

Min: Point3D

Get minimum point

SizeX property

SizeX: float

Get the size of the box in the X direction

SizeY property

SizeY: float

Get the size of the box in the Y direction

SizeZ property

SizeZ: float

Get the size of the box in the Y direction

Deflate overloaded

Deflate(size: float)

Deflate in x,y,z axis concurrently.

Deflate(x: float, y: float, z: float)

Deflate in x, y and z axis.

Get

Get() -> tuple[Point3D, Point3D]

Get minimum and maximum point

Returns:

GetCenter

GetCenter() -> Point3D

Get box center point

Returns:

GetMax

GetMax() -> Point3D

Get maximum point

Returns:

GetMin

GetMin() -> Point3D

Get minimum point

Returns:

GetSizeX

GetSizeX() -> float

Get the size of the box in the X direction

Returns:

  • float

    delta X value

GetSizeY

GetSizeY() -> float

Get the size of the box in the Y direction

Returns:

  • float

    delta Y value

GetSizeZ

GetSizeZ() -> float

Get the size of the box in the Y direction

Returns:

  • float

    delta Y value

Inflate overloaded

Inflate(x: float, y: float, z: float)

ame Inflate and deflate minmax box

Inflate in x, y and z axis.

Inflate(size: float)

Inflate in x,y,z axis concurrently.

IsContaining

IsContaining(box: MinMax3D) -> bool

Is box inside this box

Parameters:

  • box (MinMax3D) –

    Potentially contained box

Returns:

  • bool

    true, if is inside, otherwise false

IsValid

IsValid() -> bool

Test if box is valid

Returns:

  • bool

    true, if box valid, otherwise false

Overlaps

Overlaps(box: MinMax3D) -> bool

Does box overlap this box

Parameters:

Returns:

  • bool

    true, if boxes overlap, otherwise false

Reset

Reset()

Set min point to [DBL_MAX,DBL_MAX,DBL_MAX] and max point to [-DBL_MAX,-DBL_MAX,-DBL_MAX]

Set

Set(min: Point3D, max: Point3D)

Set minimum and maximum point

Parameters:

SetMax

SetMax(max: Point3D)

Set maximum point

Parameters:

SetMin

SetMin(min: Point3D)

Set minimum point

Parameters:

__add__

__add__(minmax: MinMax3D) -> MinMax3D

Expand MinMax3D box.

Expands the MinMax3D box by the box given in parameter minmax

Parameters:

  • minmax (MinMax3D) –

    MinMax3D to be added

Returns:

__eq__

__eq__(minmax: MinMax3D) -> object

Comparison of minmax objects without tolerance.

Be careful, this method work without tolerance!

Parameters:

  • minmax (MinMax3D) –

    Compared minmax.

Returns:

  • object

    True when minmax objects are equal, otherwise false.

__iadd__ overloaded

__iadd__(minmax: MinMax3D) -> MinMax3D

Expand MinMax3D box.

Expands the MinMax3D box by the box given in parameter minmax

Parameters:

  • minmax (MinMax3D) –

    MinMax3D to be added

Returns:

__iadd__(point: Point3D) -> MinMax3D

Expand MinMax3D box.

Expands the MinMax3D box by the Point3D given in parameter point

Parameters:

  • point (Point3D) –

    Point3D to be added

Returns:

__init__ overloaded

__init__()

Initialize

__init__(min: Point3D, max: Point3D)

Set constructor

Initialize MinMax box with given MIN and MAX points.

Parameters:

__init__(point: Point3D)

Set constructor

Initialize MinMax box with given point.

Parameters:

__init__(minmax: MinMax3D)

Copy constructor.

Parameters:

  • minmax (MinMax3D) –

    MinMax3D to be copied

__repr__

__repr__() -> str

Convert to string