Skip to content

AttributeDate

Canonical path: NemAll_Python_BaseElements.AttributeDate

Bases: Attribute

Date attribute

Methods:

  • __eq__

    Equal operator

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __ne__

    Unequal operator

  • __repr__

    Convert to string

Attributes:

  • Day (int) –

    Get the day value

  • Month (int) –

    Get the month value

  • Year (int) –

    Get the year value

Day property writable

Day: int

Get the day value

Month property writable

Month: int

Get the month value

Year property writable

Year: int

Get the year value

__eq__

__eq__(element: AttributeDate) -> bool

Equal operator

Parameters:

Returns:

  • bool

    Elements are equal: true/false

__init__ overloaded

__init__()

Initialize

__init__(id: int, day: int, month: int, year: int)

Constructor

Parameters:

  • id (int) –

    Attribute id

  • day (int) –

    Day

  • month (int) –

    Month

  • year (int) –

    Year

__init__(element: AttributeDate)

Copy constructor

Parameters:

__ne__

__ne__(element: AttributeDate) -> bool

Unequal operator

Parameters:

Returns:

  • bool

    Elements are unequal: true/false

__repr__

__repr__() -> str

Convert to string