Skip to content

DrawingTypeService

Canonical path: NemAll_Python_BaseElements.DrawingTypeService

Utility for processing the drawing type.

This class provides methods for processing the settings regarding drawing types, such as changing the current drawing type or getting the drawing type description based on the ID

Classes:

Methods:

DefaultDrawingTypes

Canonical path: NemAll_Python_BaseElements.DrawingTypeService.DefaultDrawingTypes

Bases: Enum

Definition of the default drawing types

Methods:

Attributes:

eBuildingAlterationDrawing class-attribute instance-attribute

eBuildingAlterationDrawing = 309

Building alteration drawing

eBuildingAlterationDrawingColored class-attribute instance-attribute

eBuildingAlterationDrawingColored = 310

Building alteration drawing colored

eBuildingDrawing class-attribute instance-attribute

eBuildingDrawing = 303

Building drawing

eDesignDrawing class-attribute instance-attribute

eDesignDrawing = 302

Design drawing

eGeneralArrangementDrawing class-attribute instance-attribute

eGeneralArrangementDrawing = 307

General arrangement drawing

eKeyPlan class-attribute instance-attribute

eKeyPlan = 306

Key plan

ePresentationDrawing class-attribute instance-attribute

ePresentationDrawing = 305

Presentation drawing

eReinforcementDrawing class-attribute instance-attribute

eReinforcementDrawing = 308

Reinforcement drawing

eSchematicDesignDrawing class-attribute instance-attribute

eSchematicDesignDrawing = 301

Schematic design drawing

eWorkingDrawing class-attribute instance-attribute

eWorkingDrawing = 304

Working drawing

__getitem__

__getitem__(key: str | int | float) -> DefaultDrawingTypes

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

GetCurrentDrawingTypeDescription staticmethod

GetCurrentDrawingTypeDescription(doc: DocumentAdapter) -> str

Get the description of the current drawing type

Parameters:

Returns:

  • str

    Description of the current drawing type

GetCurrentDrawingTypeId staticmethod

GetCurrentDrawingTypeId(doc: DocumentAdapter) -> int

Get the current drawing type ID

Parameters:

Returns:

  • int

    Current drawing type ID

GetDrawingTypeDescription staticmethod

GetDrawingTypeDescription(doc: DocumentAdapter, drawingTypeId: int) -> str

Get the description of the drawing type

Parameters:

  • doc (DocumentAdapter) –

    Document

  • drawingTypeId (int) –

    Drawing type ID

Returns:

  • str

    Description of the drawing type

GetDrawingTypeDescriptions staticmethod

GetDrawingTypeDescriptions(doc: DocumentAdapter) -> VecStringList

Get the description of the drawing types

Parameters:

Returns:

GetDrawingTypeIdFromDescription staticmethod

GetDrawingTypeIdFromDescription(
    doc: DocumentAdapter, typeDescription: str
) -> int

Get the ID of the drawing type from the description

Parameters:

  • doc (DocumentAdapter) –

    Document

  • typeDescription (str) –

    Drawing type description

Returns:

  • int

    ID of the drawing type

SetDrawingTypeId staticmethod

SetDrawingTypeId(drawingTypeId: int)

Set the drawing type ID

Parameters:

  • drawingTypeId (int) –

    ID of the drawing type