Skip to content

MacroSlideProperties

Canonical path: NemAll_Python_BasisElements.MacroSlideProperties

Properties of the macro slide

Methods:

  • __eq__

    equal operator

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert to string

Attributes:

EndScaleRange property writable

EndScaleRange: float

The upper limit of the scale range in which the slide will be drawn

OffsetOfReferencePoint1 property writable

OffsetOfReferencePoint1: Vector3D

Get the First offset value to reference point

OffsetOfReferencePoint2 property writable

OffsetOfReferencePoint2: Vector3D

Get the Second offset value to reference point

ReferencePoint property writable

ReferencePoint: Point3D

Get the Reference point of this slide

ResizeSettingVx property writable

ResizeSettingVx: CombinationType

The resizing combination setting for x direction

ResizeSettingVy property writable

ResizeSettingVy: CombinationType

The resizing combination setting for y direction

ResizeSettingVz property writable

ResizeSettingVz: CombinationType

The resizing combination setting for z direction

StartScaleRange property writable

StartScaleRange: float

The lower limit of the scale range in which the slide will be drawn

Type property writable

Get the Type of macro slide

VisibilityGeo2D property writable

VisibilityGeo2D: bool

Whether the slide should be considered as 2D element (ex. to be visible in ground view)

VisibilityGeo3D property writable

VisibilityGeo3D: bool

Whether the slide should be considered as 3D element (ex. to be visible in isometric view)

VisibilityLayerA property writable

VisibilityLayerA: bool

Whether the slide should be visible on the smart symbol foil A

VisibilityLayerB property writable

VisibilityLayerB: bool

Whether the slide should be visible on the smart symbol foil B

VisibilityLayerC property writable

VisibilityLayerC: bool

Whether the slide should be visible on the smart symbol foil C

__eq__

__eq__(prop: MacroSlideProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__ overloaded

__init__()

Initialize

__init__(element: MacroSlideProperties)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string