Skip to content

BSplineSurface3D

Canonical path: NemAll_Python_Geometry.BSplineSurface3D

3D bsplinesrfc class for 3D (non uniform, rational) B-spline surface geometry

Methods:

Attributes:

  • Points (None) –

    Get the points property

  • UClosed (None) –

    Get and set the closed property

  • UDegree (None) –

    Get and set the degree property

  • UKnots (None) –

    Get and set the uknots property

  • UPeriodic (None) –

    Get and set the periodic property

  • VClosed (None) –

    Get and set the closed property

  • VDegree (None) –

    Get and set the degree property

  • VKnots (None) –

    Get and set the vknots property

  • VPeriodic (None) –

    Get and set the periodic property

  • Weights (None) –

    Get and set the weights property

Points property

Points: None

Get the points property

:type: None

UClosed property

UClosed: None

Get and set the closed property

:type: None

UDegree property

UDegree: None

Get and set the degree property

:type: None

UKnots property

UKnots: None

Get and set the uknots property

:type: None

UPeriodic property

UPeriodic: None

Get and set the periodic property

:type: None

VClosed property

VClosed: None

Get and set the closed property

:type: None

VDegree property

VDegree: None

Get and set the degree property

:type: None

VKnots property

VKnots: None

Get and set the vknots property

:type: None

VPeriodic property

VPeriodic: None

Get and set the periodic property

:type: None

Weights property

Weights: None

Get and set the weights property

:type: None

Clear

Clear()

Clear data, getting invalid state

Get

Get() -> tuple

Get all surface members

Returns:

  • tuple

    all control points,

  • tuple

    all control points weights,

  • tuple

    knots in u direction,

  • tuple

    knots in v direction,

  • tuple

    degree in u direction,

  • tuple

    degree in v direction,

  • tuple

    periodic in u direction,

  • tuple

    periodic in v direction,

  • tuple

    closed in u direction,

  • tuple

    closed in v direction

GetCenterPoint

GetCenterPoint() -> Point3D

Get center point

Returns:

GetNormalVector

GetNormalVector(uv: Point2D) -> tuple

Evaluate normal vector for given parameters

Parameters:

Returns:

result vector

GetPoints

GetPoints() -> Point3DList

Get control points

Returns:

GetUDegree

GetUDegree() -> int

Get surface u-degree

Returns:

  • int

    surface degree

GetUKnots

GetUKnots() -> VecDoubleList

Get u-knot vector

Returns:

GetUPointsCount

GetUPointsCount() -> int

Get control points count in u-direction

Returns:

  • int

    size_t control points count

GetVDegree

GetVDegree() -> int

Get surface v-degree

Returns:

  • int

    surface degree

GetVKnots

GetVKnots() -> VecDoubleList

Get v-knot vector

Returns:

GetVPointsCount

GetVPointsCount() -> int

Get control points count in v-direction

Returns:

  • int

    size_t control points count

GetWeights

GetWeights() -> VecDoubleList

Get control points weights

Returns:

IsPlanar

IsPlanar() -> bool

Check if surface is planar

Returns:

  • bool

    bool true = yes

IsRational

IsRational() -> bool

Check if the surface is rational

Returns:

  • bool

    bool true = rational

IsUClosed

IsUClosed() -> bool

Check if the surface is closed in U direction

Returns:

  • bool

    bool true = closed

IsUPeriodic

IsUPeriodic() -> bool

Check if the surface is periodic in U direction

Returns:

  • bool

    bool true = periodic

IsVClosed

IsVClosed() -> bool

Check if the surface is closed in V direction

Returns:

  • bool

    bool true = closed

IsVPeriodic

IsVPeriodic() -> bool

Check if the surface is periodic in V direction

Returns:

  • bool

    bool true = periodic

IsValid

IsValid() -> bool

Check surface validity

Returns:

  • bool

    bool valid = true

Set

Set(
    points: Point3DList,
    weights: VecDoubleList,
    uknots: VecDoubleList,
    vknots: VecDoubleList,
    udegree: int,
    vdegree: int,
    isUPeriodic: bool,
    isVPeriodic: bool,
    isUClosed: bool,
    isVClosed: bool,
)

Set all surface members

Parameters:

  • points (Point3DList) –

    all control points

  • weights (VecDoubleList) –

    all control points weights

  • uknots (VecDoubleList) –

    knots in u direction

  • vknots (VecDoubleList) –

    knots in v direction

  • udegree (int) –

    degree in u direction

  • vdegree (int) –

    degree in v direction

  • isUPeriodic (bool) –

    periodic in u direction

  • isVPeriodic (bool) –

    periodic in v direction

  • isUClosed (bool) –

    closed in u direction

  • isVClosed (bool) –

    closed in v direction

SetUDegree

SetUDegree(degree: int)

Set surface v-degree

Parameters:

  • degree (int) –

    desired degree

SetUKnots

SetUKnots(knots: VecDoubleList)

Set u-knot vector

Parameters:

SetVDegree

SetVDegree(degree: int)

Set surface v-degree

Parameters:

  • degree (int) –

    desired degree

SetVKnots

SetVKnots(knots: VecDoubleList)

Set v-knot vector

Parameters:

SetWeights

SetWeights(weights: VecDoubleList)

Set weights for control points

Parameters:

__eq__

__eq__(bsplinesrfc: BSplineSurface3D) -> object

Comparison of bsplinesrfcs without tolerance.

Be careful, this method work without tolerance!

Parameters:

Returns:

  • object

    True when bsplinesrfcs are equal, otherwise false.

__init__ overloaded

__init__()

Initialize

__init__(
    points: Point3DList,
    weights: VecDoubleList,
    uknots: VecDoubleList,
    vknots: VecDoubleList,
    udegree: int,
    vdegree: int,
    isUPeriodic: bool,
    isVPeriodic: bool,
    isUClosed: bool,
    isVClosed: bool,
)

Constructor.

Parameters:

  • points (Point3DList) –

    all control points

  • weights (VecDoubleList) –

    all control points weights

  • uknots (VecDoubleList) –

    knots in u direction

  • vknots (VecDoubleList) –

    knots in v direction

  • udegree (int) –

    degree in u direction

  • vdegree (int) –

    degree in v direction

  • isUPeriodic (bool) –

    periodic in u direction

  • isVPeriodic (bool) –

    periodic in v direction

  • isUClosed (bool) –

    closed in u direction

  • isVClosed (bool) –

    closed in v direction

__init__(surface: BSplineSurface3D)

Copy constructor.

Parameters:

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string