Skip to content

Path

Canonical path: NemAll_Python_Geometry.Path

Methods:

  • Clear

    Clear all geometries from path

  • Count

    Count of geometries stored in path

  • GetElement

    Get the element by index

  • IsEmpty

    Tests whether no elements are present

  • Remove

    Remove geometry at the specified position

  • Reverse

    Reverse orientation of the PathElement

  • __iter__

    Get the iterator

Clear

Clear()

Clear all geometries from path

Count

Count() -> int

Count of geometries stored in path

Returns:

  • int

    Count of geometries.

GetElement

GetElement(arg2: int) -> object

Get the element by index

Parameters:

  • index

    Element index.

Returns:

  • object

    Element

IsEmpty

IsEmpty() -> bool

Tests whether no elements are present

Returns:

  • bool

    True for an empty, otherwise false.

Remove

Remove(position: int) -> eGeometryErrorCode

Remove geometry at the specified position

Parameters:

  • position (int) –

    Specified position of removed geometry.

Returns:

Reverse

Reverse()

Reverse orientation of the PathElement

__iter__

__iter__() -> PathIterator

Get the iterator