Skip to content

RoomProperties

Canonical path: NemAll_Python_ArchElements.RoomProperties

Bases: ArchBaseProperties

Implementation of the Room properties

Methods:

Attributes:

Function property writable

Function: str

Get the function

StoreyCode property writable

StoreyCode: str

Get the storey code

GetAttributes

GetAttributes(
    doc: DocumentAdapter, onlyModifiable: bool
) -> list[int | float | str]

Get the room attributes

Parameters:

  • doc (DocumentAdapter) –

    Document

  • onlyModifiable (bool) –

    when true, gets only modifiable attributes, otherwise gets all attributes

Returns:

  • list[int | float | str]

    List with the attributes represented with tuples like (attributeID, attributeValue)

GetFunction

GetFunction() -> str

Get the function

Returns:

  • str

    Function

GetStoreyCode

GetStoreyCode() -> str

Get the storey code

Returns:

  • str

    Storey code

GetText

GetText(number: int) -> str

Get the value of the attributes Text1 to Text5

Parameters:

  • number (int) –

    Number (1-5 allowed)

Returns: Value of the attribute

SetAttribute

Set the attribute

Parameters:

SetFunction

SetFunction(name: str)

Set the function

Parameters:

  • name (str) –

    Function

SetStoreyCode

SetStoreyCode(storeyCode: str)

Set the storey code

Parameters:

  • storeyCode (str) –

    Storey code

SetText

SetText(text: str, number: int)

Set a value to the attributes Text1 to Text5

Parameters:

  • text (str) –

    Desired value of the attribute

  • number (int) –

    Number (1-5 allowed)

__init__ overloaded

__init__()

Initialize

__init__(RoomProp: RoomProperties)

Copy constructor

Parameters: