Skip to content

Cuboid3D

Canonical path: NemAll_Python_Geometry.Cuboid3D

3D cuboid

Methods:

Attributes:

  • HeightVector (None) –

    Get and set the height vector property

  • LengthVector (None) –

    Get and set the length vector property

  • RefPoint (None) –

    Get and set the ref point property

  • StartPoint (None) –

    Get and set the start point property

  • WidthVector (None) –

    Get and set the width vector property

HeightVector property

HeightVector: None

Get and set the height vector property

:type: None

LengthVector property

LengthVector: None

Get and set the length vector property

:type: None

RefPoint property

RefPoint: None

Get and set the ref point property

:type: None

StartPoint property

StartPoint: None

Get and set the start point property

:type: None

WidthVector property

WidthVector: None

Get and set the width vector property

:type: None

GetBottomFacePolygon

GetBottomFacePolygon() -> Polygon3D

Get the boundary polygon of bottom face of the cuboid

Returns:

GetGroundPlane

GetGroundPlane() -> Plane3D

Get ground plane ( ref point + Z-vector ).

Returns:

GetHeight

GetHeight() -> float

Get height.

Returns:

  • float

    Size of Z-vector ( vector3 ).

GetLength

GetLength() -> float

Get length.

Returns:

  • float

    Size of X-vector ( vector1 ).

GetRefPoint

GetRefPoint() -> Point3D

Get reference point.

Returns:

GetRelStartPoint

GetRelStartPoint() -> Point3D

Get start point in relative coordinates.

Returns:

  • Point3D

    Constant reference to the start point.

GetStartPoint

GetStartPoint() -> Point3D

Get start point in world coordinates.

Returns:

GetTopFacePolygon

GetTopFacePolygon() -> Polygon3D

Get the boundary polygon of top face of the cuboid

Returns:

GetVector

GetVector(index: int) -> Vector3D

Get given vector.

Parameters:

  • index (int) –

    Index of the vector.

Returns:

GetWidth

GetWidth() -> float

Get width.

Returns:

  • float

    Size of Y-vector ( vector2 ).

Set overloaded

Set(
    refPoint: Point3D,
    startPoint: Point3D,
    vec1: Vector3D,
    vec2: Vector3D,
    vec3: Vector3D,
)

Set the Cuboid.

Parameters:

  • refPoint (Point3D) –

    Reference point in world coordinate system.

  • startPoint (Point3D) –

    Start point of cuboid.

  • vec1 (Vector3D) –

    X-vector.

  • vec2 (Vector3D) –

    Y-vector.

  • vec3 (Vector3D) –

    Z-vector.

Set(cuboid: Cuboid3D)

Initialize from cuboid.

Parameters:

  • cuboid (Cuboid3D) –

    Cuboid which will be copied.

SetHeight

SetHeight(height: float)

Set height.

Parameters:

  • height (float) –

    New size of Z-vector ( vector3 ).

SetLength

SetLength(length: float)

Set length.

Parameters:

  • length (float) –

    New size of X-vector ( vector1 ).

SetRefPoint

SetRefPoint(refPoint: Point3D)

Set reference point.

Parameters:

  • refPoint (Point3D) –

    New reference point.

SetStartPoint

SetStartPoint(startPoint: Point3D)

Set start point.

Parameters:

  • startPoint (Point3D) –

    New start point ( in world coordinates ).

SetVector

SetVector(vec: Vector3D, index: int)

Set the vector.

Parameters:

  • vec (Vector3D) –

    New vector.

  • index (int) –

    Index pf the vector.

SetWidth

SetWidth(width: float)

Set width.

Parameters:

  • width (float) –

    New size of Y-vector ( vector2 ).

__eq__

__eq__(cuboid: Cuboid3D) -> object

Comparison of cuboids without tolerance.

Be careful, this method work without tolerance!

Parameters:

  • cuboid (Cuboid3D) –

    Compared cuboid.

Returns:

  • object

    True when cuboids are equal, otherwise false.

__init__ overloaded

__init__()

Initialize

__init__(cuboid: Cuboid3D)

Copy constructor.

Parameters:

  • cuboid (Cuboid3D) –

    Cuboid which will be copied.

__init__(
    refPoint: Point3D,
    startPoint: Point3D,
    vec1: Vector3D,
    vec2: Vector3D,
    vec3: Vector3D,
)

Constructor.

Parameters:

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string