Skip to content

FillingProperties

Canonical path: NemAll_Python_BasisElements.FillingProperties

Properties of the filling

Methods:

Attributes:

  • DirectionToReferenceLine (None) –

    The edge index of the outline polyline to align the filling to. Relevant, when the property UseDirectionToReferenceLine is set to true.

  • FirstColor (None) –

    First color

  • RotationAngle (None) –

    Rotation angle. Relevant, when UseGradientFilling is set to True.

  • SecondColor (None) –

    Second color. Relevant, when UseGradientFilling is set to True.

  • ShadingType (None) –

    Shading style. Relevant, when the UseGradientFilling is set to True.

  • TranslationType (None) –

    Color gradients type. Relevant, when UseGradientFilling is set to True.

  • UseDirectionToReferenceLine (None) –

    Whether to align the direction of the filling to a certain edge of the outline polyline. When set to True, the index of the edge is to be specified in DirectionToReferenceLine.

  • UseGradientFilling (None) –

    Whether to use gradient filling.

  • VariantType (None) –

    Gradient variant type. Relevant, when UseGradientFilling is set to True.

DirectionToReferenceLine property

DirectionToReferenceLine: None

The edge index of the outline polyline to align the filling to. Relevant, when the property UseDirectionToReferenceLine is set to true.

FirstColor property

FirstColor: None

First color

RotationAngle property

RotationAngle: None

Rotation angle. Relevant, when UseGradientFilling is set to True.

SecondColor property

SecondColor: None

Second color. Relevant, when UseGradientFilling is set to True.

ShadingType property

ShadingType: None

Shading style. Relevant, when the UseGradientFilling is set to True.

TranslationType property

TranslationType: None

Color gradients type. Relevant, when UseGradientFilling is set to True.

UseDirectionToReferenceLine property

UseDirectionToReferenceLine: None

Whether to align the direction of the filling to a certain edge of the outline polyline. When set to True, the index of the edge is to be specified in DirectionToReferenceLine.

UseGradientFilling property

UseGradientFilling: None

Whether to use gradient filling.

VariantType property

VariantType: None

Gradient variant type. Relevant, when UseGradientFilling is set to True.

__eq__

__eq__(prop: FillingProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__

__init__()

Initialize

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string