Skip to content

HiddenCalculationParameters

Canonical path: NemAll_Python_Geometry.HiddenCalculationParameters

Parameters of hidden calculation.

Methods:

  • SetObserverMatrix

    Calculates observer matrix from 2 points.

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

Attributes:

AdjacentEdgesMaxAngle property writable

AdjacentEdgesMaxAngle: Angle

Adjacent edges max angle.

Maximal angle in which adjacent edges will be joined.

GetHiddenLines property writable

GetHiddenLines: bool

Determines if get also hidden lines.

If false only visible lines are produced during hidden calculation.

ObserverMatrix property writable

ObserverMatrix: Matrix3D

Observer matrix;

SetObserverMatrix

SetObserverMatrix(eyePoint: Point3D, viewPoint: Point3D)

Calculates observer matrix from 2 points.

Parameters:

  • eyePoint (Point3D) –

    Eye point.

  • viewPoint (Point3D) –

    View point.

__init__ overloaded

__init__()

Initialize

__init__(param: HiddenCalculationParameters)

Copy constructor.