Skip to content

VerticalOpeningGeometryProperties

Canonical path: NemAll_Python_ArchElements.VerticalOpeningGeometryProperties

Implementation of the vertical opening geometry properties

Methods:

Attributes:

Depth property writable

Depth: float

Get the depth

ProfilePath property writable

ProfilePath: str

Get the full name of the profile

RiseAtBottom property writable

RiseAtBottom: float

Get the rise at the bottom

RiseAtTop property writable

RiseAtTop: float

Get the rise at the top

SegmentsAtBottom property writable

SegmentsAtBottom: int

Get the segments of rise at bottom

SegmentsAtTop property writable

SegmentsAtTop: int

Get the segments of rise at top

Shape property writable

Get the opening shape type

ShapePolygon property writable

ShapePolygon: Polygon2D

Get the shape polygon

Width property writable

Width: float

Get the width

__init__

Copy constructor

Parameters: