Skip to content

FixtureProperties

Canonical path: NemAll_Python_Palette.FixtureProperties

Methods:

Attributes:

  • Element (None) –

    Property access for the element

  • Group (None) –

    Property access for the group

  • Path (None) –

    Property access for the path

  • PathShortcut (None) –

    Property access for the path shortcut

Element property

Element: None

Property access for the element

:type: None

Group property

Group: None

Property access for the group

:type: None

Path property

Path: None

Property access for the path

:type: None

PathShortcut property

PathShortcut: None

Property access for the path shortcut

:type: None

GetElement

GetElement() -> str

Get the element

Returns:

  • str

    Element

GetGroup

GetGroup() -> str

Get the group

Returns:

  • str

    Group

GetLastFixturePath staticmethod

GetLastFixturePath() -> str

Get the last fixture path

Returns:

  • str

    Last fixture path

GetPath

GetPath() -> str

Get the path

Returns:

  • str

    Path

OpenFixtureDialog staticmethod

OpenFixtureDialog(fixturePath: str) -> str

Open the symbol library dialog

Returns:

  • str

    result path

Parameters:

  • fixturePath (str) –

    Path to .sym file

__eq__

__eq__(other: FixtureProperties) -> object

Comparison of fixture properties.

Parameters:

Returns:

  • object

    True when fixture properties are equal, otherwise false.

__init__ overloaded

__init__()

Initialize

__init__(pathShortcut: str, group: str, element: str)

Constructor

Parameters:

  • pathShortcut (str) –

    Path shortcut (Office/Project/Privat)

  • group (str) –

    Group name

  • element (str) –

    Element name

__init__(FixtureProperties: FixtureProperties)

Copy Constructor

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string