Skip to content

PlaneMeshPlacement

Canonical path: NemAll_Python_Reinforcement.PlaneMeshPlacement

Bases: ReinfElement, AllplanElement

Implementation of the mesh placement element

Methods:

Attributes:

CommonProperties property writable

CommonProperties: CommonProperties

Get the common properties

MeshPolygon property writable

MeshPolygon: Polygon3D

Get the shape polyline

PositionNumber property writable

PositionNumber: int

Get the position number

GetCommonProperties

GetCommonProperties() -> CommonProperties

Get the common properties

Returns:

GetMeshData

GetMeshData() -> MeshData

Get the mesh data

Returns:

GetMeshLength

GetMeshLength() -> float

Get the mesh length

Returns:

  • float

    Mesh length

GetMeshPolygon

GetMeshPolygon() -> Polygon3D

Get the shape polyline

Returns:

GetMeshWidth

GetMeshWidth() -> float

Get the mesh width

Returns:

  • float

    Mesh width

GetPositionNumber

GetPositionNumber() -> int

Get the position number

Returns:

  • int

    Position number

IsValid

IsValid() -> bool

Get the state of the shape

Returns:

  • bool

    Shape is valid: true/false

Move

Move(transVec: Vector3D)

Move the placement

Parameters:

SetCommonProperties

SetCommonProperties(commonProp: CommonProperties)

Set the common properties

Parameters:

SetMeshPolygon

SetMeshPolygon(shape: Polygon3D)

Set the reinforcement shape

Parameters:

SetPositionNumber

SetPositionNumber(positionNumber: int)

Set the position number

Parameters:

  • positionNumber (int) –

    Position number

Transform

Transform(transMat: Matrix3D)

Transform the placement

Parameters:

  • transMat (Matrix3D) –

    Transformation matrix

__init__ overloaded

__init__()

Initialize

__init__(placement: PlaneMeshPlacement)

Copy constructor

Parameters:

__init__(
    positionNumber: int,
    meshData: MeshData,
    meshLength: float,
    meshWidth: float,
    meshPolygon: Polygon3D,
)

Constructor

Parameters:

  • positionNumber (int) –

    Position number

  • meshData (MeshData) –

    Mesh data

  • meshLength (float) –

    Mesh length

  • meshWidth (float) –

    Mesh width

  • meshPolygon (Polygon3D) –

    Mesh polygon

__repr__

__repr__() -> str

Convert to string