Skip to content

CommonProperties

Canonical path: NemAll_Python_BaseElements.CommonProperties

Representation of format properties, common for all kind of Allplan elements, such as General elements, architectural components or reinforcement. This class contains information about e.g. pen thickness, stroke type and color, with which an Allplan element is drawn in the viewport.

Methods:

Attributes:

Activated property writable

Activated: bool

Get the activated state

Color property writable

Color: int

Get the color

ColorByLayer property writable

ColorByLayer: bool

Get the color by layer state

ConstructionLine property writable

ConstructionLine: bool

Get the construction line state

DrawOrder property writable

DrawOrder: int

Get the drawOrder

ForceColor property writable

ForceColor: bool

Get flag if force color is set

HelpConstruction property writable

HelpConstruction: bool

Get flag if pen and stroke is help construction

InSpecialWindow property writable

InSpecialWindow: bool

Get the special window visibility

Layer property writable

Layer: int

Get the layer

Marked property writable

Marked: bool

Get the marked state

PageNumber property writable

PageNumber: int

Get the page number

Pen property writable

Pen: int

Get the pen

PenByLayer property writable

PenByLayer: bool

Get the pen by layer state

Printable property writable

Printable: bool

Get the printable state

Stroke property writable

Stroke: int

Get the stroke

StrokeByLayer property writable

StrokeByLayer: bool

Get the stroke by layer state

Visible property writable

Visible: bool

Get the visible flag state

VisibleInsideZoomwindows property writable

VisibleInsideZoomwindows: bool

Get the visible inside zoom window state

VisibleOutsideZoomwindows property writable

VisibleOutsideZoomwindows: bool

Get the visible outside zoom window state

GetColorPenStrokeByLayerFromLayerNumber staticmethod

GetColorPenStrokeByLayerFromLayerNumber(
    layernumber: int,
) -> list[int] | VecIntList

Layer number

Returns:

  • list[int] | VecIntList

    [0] = pen,[1] = stroke, [2] color

GetGlobalProperties

GetGlobalProperties()

Get the global properties

__eq__

__eq__(props: CommonProperties) -> object

Compare operator

Parameters:

Returns:

  • object

    Properties a equal: true/false

__init__ overloaded

__init__()

Initialize

__init__(element: CommonProperties)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string