Skip to content

PrecastPropertiesService

Canonical path: NemAll_Python_IFW_ElementAdapter.PrecastPropertiesService

Methods:

GetPositionNumber staticmethod

GetPositionNumber() -> str

Get the precast element position number

Returns:

  • str

    position number

GetPositionNumberPure staticmethod

GetPositionNumberPure() -> int

Get the precast element position number

Returns:

  • int

    position number

GetPrecastElementTypeDescription staticmethod

GetPrecastElementTypeDescription(arg2: bool) -> str

Get the precast element description (new wall system)

Returns:

  • str

    description