Skip to content

PrecastMWSElement

Canonical path: NemAll_Python_Precast.PrecastMWSElement

Bases: PrecastElement, AllplanElement

PrecastMWSElement class

Methods:

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert the list to a string

Attributes:

  • Factory (None) –

    Property for Factory

  • IndexLongitBar (None) –

    Index of the longitudinal bar in the Reinfrocementlist

  • LongitBarHeight (None) –

    Heightposition of the longitudinal bar (1 = Position 1, 2 = Position 2)

  • Name (None) –

    Property for Name

  • Number (None) –

    Property for Number

  • Piecefactor (None) –

    Property for Piecefactor

  • ReinforcementList (None) –

    list of reinforcement placements

  • SegmentNumber (None) –

    Number of the main segement of the transversal shape

  • SegmentPointList (None) –

    Pointlist of the transversal shape

  • SegmentVector (None) –

    Property for Norm Catalog

Factory property

Factory: None

Property for Factory Value type: str

:type: None

IndexLongitBar property

IndexLongitBar: None

Index of the longitudinal bar in the Reinfrocementlist Value type: int

:type: None

LongitBarHeight property

LongitBarHeight: None

Heightposition of the longitudinal bar (1 = Position 1, 2 = Position 2) Value type: int

:type: None

Name property

Name: None

Property for Name Value type: str

:type: None

Number property

Number: None

Property for Number Value type: int

:type: None

Piecefactor property

Piecefactor: None

Property for Piecefactor Value type: int

:type: None

ReinforcementList property

ReinforcementList: None

list of reinforcement placements Value type: list

:type: None

SegmentNumber property

SegmentNumber: None

Number of the main segement of the transversal shape Value type: int

:type: None

SegmentPointList property

SegmentPointList: None

Pointlist of the transversal shape Value type: list

:type: None

SegmentVector property

SegmentVector: None

Property for Norm Catalog Value type: int

:type: None

__init__ overloaded

__init__()

Initialize

__init__(
    factory: str,
    name: str,
    number: int,
    piecefactor: int,
    longitBarHeight: int,
    SegmentNumber: int,
    SegmentVector: Point3D,
    SegementPointList: list,
    ReinforcementList: list,
)

Constructor

Parameters:

  • factory (str) –

    factory

  • name (str) –

    name of the MWS element

  • number (int) –

    number of the MWS element

  • piecefactor (int) –

    piecefactor of the MWS element

  • longitBarHeight (int) –

    longitBarHeight of the MWS element

  • SegmentNumber (int) –

    SegmentNumber of the MWS element

  • SegmentVector (Point3D) –

    SegmentVector of the MWS element

  • SegementPointList (list) –

    SegementPointList of the MWS element

  • ReinforcementList (list) –

    ReinforcementList of the MWS element

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string