Skip to content

AssociativeViewProperties

Canonical path: NemAll_Python_BasisElements.AssociativeViewProperties

Properties of the associative views and sections

WARNING!!: Associative views and sections are deprecated and not supported in Allplan >=2023! Use UVSs instead (represented by ViewSectionElement class)

Methods:

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

Attributes:

AdjacentEdges property

AdjacentEdges: None

Set/get the adjacent edges state

:type: None

ColorHiddenEdge property

ColorHiddenEdge: None

Set/get the color of the hidden edges

:type: None

ColorVisibleEdge property

ColorVisibleEdge: None

Set/get the color of the visible edges

:type: None

ConvertTo2D property

ConvertTo2D: None

Set/get the convert to 2D state

:type: None

ElementRepresentation property

ElementRepresentation: None

Set/get the element representation

:type: None

Hidden property

Hidden: None

Set/get the hidden state

:type: None

LayerBoundaryLine property

LayerBoundaryLine: None

Set/get the layer of the boundary line

:type: None

LayerFinishLine property

LayerFinishLine: None

Set/get the layer of the finish line

:type: None

LayerHiddenEdge property

LayerHiddenEdge: None

Set/get the layer of the hidden edges

:type: None

LayerHiddenSectionLine property

LayerHiddenSectionLine: None

Set/get the layer of the hidden section line

:type: None

LayerSectionLine property

LayerSectionLine: None

Set/get the layer of the section line

:type: None

LayerVisibleEdge property

LayerVisibleEdge: None

Set/get the layer of the visible edges

:type: None

PenHiddenEdge property

PenHiddenEdge: None

Set/get the pen of the hidden edges

:type: None

PenVisibleEdge property

PenVisibleEdge: None

Set/get the pen of the visible edges

:type: None

RemoveAdjacentEdges property

RemoveAdjacentEdges: None

Set/get the remove adjacent edges state

:type: None

ShowHiddenEdges property

ShowHiddenEdges: None

Set/get the show hidden edges state

:type: None

ShowSectionBody property

ShowSectionBody: None

:type: None

ShowVisibleEdges property

ShowVisibleEdges: None

Set/get the show visible edges state

:type: None

StrokeHiddenEdge property

StrokeHiddenEdge: None

Set/get the stroke of the hidden edges

:type: None

StrokeVisibleEdge property

StrokeVisibleEdge: None

Set/get the stroke of the visible edges

:type: None

__init__ overloaded

__init__()

Initialize

__init__(arg2: DocumentAdapter)

Constructor

__init__(arg2: AssociativeViewProperties)

Constructor