Skip to content

Clothoid2D

Canonical path: NemAll_Python_Geometry.Clothoid2D

2D clothoid Representation class for 2D clothoid.

Methods:

Attributes:

  • EndCurvature (None) –

    Get and set the end curvature property

  • EndPoint (None) –

    Get and set the end point property

  • IsReversed (None) –

    Get and set the reversed property

  • Length (None) –

    Get and set the length property

  • Parallel (None) –

    Get and set the parallel property

  • RefPoint (None) –

    Get and set the end point property

  • StartCurvature (None) –

    Get and set the start curvature property

  • StartPoint (None) –

    Get and set the start point property

  • StartVector (None) –

    Get and set the start vector property

  • Type (None) –

    Get and set the type property

EndCurvature property

EndCurvature: None

Get and set the end curvature property

:type: None

EndPoint property

EndPoint: None

Get and set the end point property

:type: None

IsReversed property

IsReversed: None

Get and set the reversed property

:type: None

Length property

Length: None

Get and set the length property

:type: None

Parallel property

Parallel: None

Get and set the parallel property

:type: None

RefPoint property

RefPoint: None

Get and set the end point property

:type: None

StartCurvature property

StartCurvature: None

Get and set the start curvature property

:type: None

StartPoint property

StartPoint: None

Get and set the start point property

:type: None

StartVector property

StartVector: None

Get and set the start vector property

:type: None

Type property

Type: None

Get and set the type property

:type: None

GetEndCurvature

GetEndCurvature() -> float

Get end curvature.

Returns:

  • float

    double end curvature of clothoid.

GetEndPoint

GetEndPoint() -> Point2D

Get end point in world coordinate system.

Returns:

GetEndRelPoint

GetEndRelPoint() -> Point2D

Get the end point in relative coordinate system

Returns:

  • Point2D

    constant reference to Point2D.

GetIsReversed

GetIsReversed() -> bool

is clothoid reversed

Returns:

  • bool

    true/false

GetLength

GetLength() -> float

Get length of clothoid.

Returns:

  • float

    double length of clothoid.

GetParallel

GetParallel() -> float

Get parallel of clothoid.

Returns:

  • float

    double parallel of clothoid.

GetRefPoint

GetRefPoint() -> Point2D

Get reference point in world coordinate system

Returns:

GetStartCurvature

GetStartCurvature() -> float

Get start curvature.

Returns:

  • float

    double start curvature of clothoid.

GetStartPoint

GetStartPoint() -> Point2D

Get start point in world coordinate system.

Returns:

GetStartRelPoint

GetStartRelPoint() -> Point2D

Get the start point in relative coordinate system

Returns:

  • Point2D

    constant reference to Point2D.

GetStartVector

GetStartVector() -> Vector2D

Get start vector.

Returns:

  • Vector2D

    const reference to Vector2D.

GetType

GetType() -> eClothoidType

Get type of clothoid.

Returns:

Reverse

Reverse()

Reverse orientation of the Clothoid

Set

Set(clothoid: Clothoid2D)

Initialize clothoid from clothoid.

Parameters:

SetEndCurvature

SetEndCurvature(curvature: float)

Set end curvature of clothoid.

Parameters:

  • curvature (float) –

    end curvature of clothoid

SetEndPoint

SetEndPoint(point: Point2D)

Set end point in world coordinate system.

Parameters:

  • point (Point2D) –

    const reference to Point2D in World coordinate system.

SetEndRelPoint

SetEndRelPoint(point: Point2D)

Set end point in local coordinate system

Parameters:

  • point (Point2D) –

    Point2D in local coordinate system

SetLength

SetLength(length: float)

Set length of clothoid.

Parameters:

  • length (float) –

    length of clothoid.

SetParallel

SetParallel(parallel: float)

Set parallel of clothoid.

Parameters:

  • parallel (float) –

    length of clothoid.

SetRefPoint

SetRefPoint(refPoint: Point2D)

Set reference point in world coordinate system

Parameters:

  • refPoint (Point2D) –

    const reference to Point2D in World coordinate system.

SetReversed

SetReversed(flag: bool)

Set orientation.

Parameters:

  • flag (bool) –

    true for reversed, false normal orientation.

SetStartCurvature

SetStartCurvature(curvature: float)

Set start curvature of clothoid.

Parameters:

  • curvature (float) –

    start curvature of clothoid

SetStartPoint

SetStartPoint(point: Point2D)

Set start point in world coordinate system.

Parameters:

  • point (Point2D) –

    const reference to Point2D in World coordinate system.

SetStartRelPoint

SetStartRelPoint(point: Point2D)

Set start point in local coordinate system

Parameters:

  • point (Point2D) –

    Point2D in local coordinate system

SetStartVector

SetStartVector(vec: Vector2D)

Set start vector.

Parameters:

  • vec (Vector2D) –

    const reference to Vector2D.

SetType

SetType(type: eClothoidType)

Set type of clothoid.

Parameters:

__eq__

__eq__(clothoid: Clothoid2D) -> object

Comparison of clothoids without tolerance.

Be careful, this method work without tolerance!

Parameters:

Returns:

  • object

    True when clothoids are equal, otherwise false.

__init__ overloaded

__init__()

Initialize

__init__(clothoid: Clothoid2D)

Copy constructor.

Parameters:

  • clothoid (Clothoid2D) –

    Clothoid2D which will be copied.

__mul__

__mul__(matrix: Matrix2D) -> object

Matrix transformation.

Parameters:

  • matrix (Matrix2D) –

    transformation matrix.

Returns:

  • object

    Clothoid2D transformed clothoid.

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string