Skip to content

Cylinder3D

Canonical path: NemAll_Python_Geometry.Cylinder3D

3D cylinder

Methods:

Attributes:

  • Apex (None) –

    Get and set the apex property

  • LocalPlacement (None) –

    Get and set the local placement property

  • MajorRadius (None) –

    Get and set the major radius property

  • MinorRadius (None) –

    Get and set the minor radius property

Apex property

Apex: None

Get and set the apex property

:type: None

LocalPlacement property

LocalPlacement: None

Get and set the local placement property

:type: None

MajorRadius property

MajorRadius: None

Get and set the major radius property

:type: None

MinorRadius property

MinorRadius: None

Get and set the minor radius property

:type: None

GetApex

GetApex() -> Point3D

Get Apex of the Cylinder in the local coordinate system

Returns:

GetApexParent

GetApexParent() -> Point3D

Get Apex of the Cylinder in the parent coordinate system

Returns:

GetBottomCenter

GetBottomCenter() -> Point3D

Get bottom center

Returns:

  • Point3D

    center of bottom base

GetCenter

GetCenter() -> Point3D

Get Center of the Cylinder

Returns:

GetHeight

GetHeight() -> float

Get Height of the Cylinder

Returns:

  • float

    Reference to Height of the Cylinder.

GetLocalPlacement

GetLocalPlacement() -> AxisPlacement3D

Get Local Placement

Returns:

GetMajorRadius

GetMajorRadius() -> float

Get Major Radius of the Cylinder

Returns:

  • float

    Reference to Major Radius.

GetMinMax

GetMinMax() -> MinMax3D

Get MinMax of the Cylinder

Returns:

  • MinMax3D

    Reference to MinMax of the Cylinder.

GetMinorRadius

GetMinorRadius() -> float

Get Minor Radius of the Cylinder

Returns:

  • float

    Reference to Minor Radius.

GetSilhouetteLines

GetSilhouetteLines(viewMatrix: Matrix3D, bPerspective: bool) -> Line3DList

Get silhouette lines of cylinder

Parameters:

  • viewMatrix (Matrix3D) –

    View matrix

  • bPerspective (bool) –

    Flag if it is central projection or not (true / false)

Returns:

GetTopCenter

GetTopCenter() -> Point3D

Get top center

Returns:

GetXAxis

GetXAxis() -> Vector3D

Get X-Axis of the placement of the Cylinder

Returns:

GetYAxis

GetYAxis() -> Vector3D

Get Y-Axis of the placement of the Cylinder

Returns:

GetZAxis

GetZAxis() -> Vector3D

Get Z - axis of the placement of the Cylinder

Returns:

IsCircular

IsCircular() -> bool

Circularity check of the Cylinder

Returns:

  • bool

    true/false

IsOblique

IsOblique() -> bool

Perpendicularity check of the Cylinder

Returns:

  • bool

    true/false

IsValid

IsValid() -> bool

Validity check of the Cylinder

Returns:

  • bool

    true/false

SetApex

SetApex(apex: Point3D)

Set Apex in the local coordinate system

Parameters:

SetApexParent

SetApexParent(apex: Point3D)

Set Apex in the parent coordinate system

Parameters:

SetCenter

SetCenter(center: Point3D)

Set center

Parameters:

SetHeight

SetHeight(arg2: float)

Set Height of the Cylinder

Parameters:

  • height

    New height.

SetLocalPlacement overloaded

SetLocalPlacement(placement: AxisPlacement3D)

Set Local Placement.

Parameters:

SetLocalPlacement(center: Point3D, xAxis: Vector3D, zAxis: Vector3D)

Set Local Placement.

Parameters:

  • center (Point3D) –

    Center point of the placement

  • xAxis (Vector3D) –

    X-axis of the placement

  • zAxis (Vector3D) –

    Z-axis of the placement

SetMajorRadius

SetMajorRadius(arg2: float)

Set Major Radius of the Cylinder

Parameters:

  • radius

    New major radius.

SetMinorRadius

SetMinorRadius(arg2: float)

Set Minor Radius of the Cylinder

Parameters:

  • radius

    New minor radius.

__eq__

__eq__(cylinder: Cylinder3D) -> object

Comparison of cylinders without tolerance.

Be careful, this method work without tolerance!

Parameters:

Returns:

  • object

    True when cylinders are equal, otherwise false.

__init__ overloaded

__init__()

Initialize

__init__(cylinder: Cylinder3D)

Copy constructor.

Parameters:

  • cylinder (Cylinder3D) –

    Cylinder which will be copied.

__init__(
    refPlacement: AxisPlacement3D,
    radiusMajor: float,
    radiusMinor: float,
    apex: Point3D,
)

Constructor.

Height of the cylinder is z-coordinate of the Apex.

Parameters:

  • refPlacement (AxisPlacement3D) –

    Local Placement of the cylinder.

  • radiusMajor (float) –

    Major radius of the cylinder.

  • radiusMinor (float) –

    Minor radius of the cylinder.

  • apex (Point3D) –

    Center of the Top Ellipse

__init__(radiusMajor: float, radiusMinor: float, apex: Point3D)

Constructor.

Height of the cylinder is z-coordinate of the Apex.

Parameters:

  • radiusMajor (float) –

    Major radius of the cylinder.

  • radiusMinor (float) –

    Minor radius of the cylinder.

  • apex (Point3D) –

    Center of the Top Ellipse

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string