Skip to content

AxisPlacement2D

Canonical path: NemAll_Python_Geometry.AxisPlacement2D

Representation class for orthogonal axis placement

Placement is given by reference point and direction vector of local x-axis

Methods:

Attributes:

Direction property writable

Direction: Vector2D

Get direction

RefPoint property writable

RefPoint: Point2D

Get the reference point

GetDirection

GetDirection() -> Vector2D

Get direction

Returns:

GetRefPoint

GetRefPoint() -> Point2D

Get the reference point

Returns:

GetYDirection

GetYDirection() -> Vector2D

Get direction of local y-axis

Returns:

IsValid

IsValid() -> bool

Check if the placement is valid

Returns:

  • bool

    True if it is a valid placement

SetDirection

SetDirection(dir: Vector2D)

Set direction

Parameters:

  • dir (Vector2D) –

    Vector2D const reference

SetRefPoint

SetRefPoint(refPoint: Point2D)

Set reference point

Parameters:

  • refPoint (Point2D) –

    New reference point

__eq__

__eq__(axis_placement: AxisPlacement2D) -> bool

Comparison of axis placements.

Be careful, this method work without tolerance!

Parameters:

Returns:

  • bool

    True when axis placements are equal, otherwise false.

__init__ overloaded

__init__()

Initialize

__init__(placement: AxisPlacement2D)

Copy constructor.

Parameters:

  • placement (AxisPlacement2D) –

    Extruded area placement which will be copied

__init__(refPoint: Point2D, dirvector: Vector2D)

Constructor which fully constructs the element.

Parameters:

  • refPoint (Point2D) –

    reference point

  • dirvector (Vector2D) –

    direction vector

__repr__

__repr__() -> str

Convert to string