Skip to content

Ellipsoid3D

Canonical path: NemAll_Python_Geometry.Ellipsoid3D

3D ellipsoid

Methods:

  • GetCenter

    Get Center of the Ellipsoid

  • GetIsoLines

    Test whether the Ellipsoid is Sphere

  • GetLocalPlacement

    Get Local Placement

  • GetSilhouetteContour

    Get silhouette circle

  • GetXAxis

    Get X-Axis of the placement of the Ellipsoid

  • GetXRadius

    Get X Radius of the Ellipsoid

  • GetYAxis

    Get Y-Axis of the placement of the Ellipsoid

  • GetYRadius

    Get Y Radius of the Ellipsoid

  • GetZAxis

    Get Z - axis of the placement of the Ellipsoid

  • GetZRadius

    Get Z Radius of the Ellipsoid

  • IsSphere

    Test whether the Ellipsoid is Sphere

  • IsValid

    Validity check of the Ellipsoid

  • SetCenter

    Set center

  • SetLocalPlacement

    dummy, is only needed for the creation of the documentation by MkDocs

  • SetXRadius

    Set X Radius of the Ellipsoid

  • SetYRadius

    Set Y Radius of the Ellipsoid

  • SetZRadius

    Set Z Radius of the Ellipsoid

  • __eq__

    Comparison of ellipsoids without tolerance.

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert the list to a string

Attributes:

  • LocalPlacement (None) –

    Get and set the local placement property

  • XRadius (None) –

    Get and set the x radius property

  • YRadius (None) –

    Get and set the y radius property

  • ZRadius (None) –

    Get and set the z radius property

LocalPlacement property

LocalPlacement: None

Get and set the local placement property

:type: None

XRadius property

XRadius: None

Get and set the x radius property

:type: None

YRadius property

YRadius: None

Get and set the y radius property

:type: None

ZRadius property

ZRadius: None

Get and set the z radius property

:type: None

GetCenter

GetCenter() -> Point3D

Get Center of the Ellipsoid

Returns:

GetIsoLines

GetIsoLines(USegmentsCount: int, VSegmentsCount: int) -> Arc3DList

Test whether the Ellipsoid is Sphere

Parameters:

  • USegmentsCount (int) –

    count of circles

  • VSegmentsCount (int) –

    count of circles

Returns:

GetLocalPlacement

GetLocalPlacement() -> AxisPlacement3D

Get Local Placement

Returns:

GetSilhouetteContour

GetSilhouetteContour(viewMatrix: Matrix3D, bPerspective: bool) -> Arc3D

Get silhouette circle

Parameters:

  • viewMatrix (Matrix3D) –

    view matrix

  • bPerspective (bool) –

    central perspective true/false

Returns:

GetXAxis

GetXAxis() -> Vector3D

Get X-Axis of the placement of the Ellipsoid

Returns:

GetXRadius

GetXRadius() -> float

Get X Radius of the Ellipsoid

Returns:

  • float

    Reference to X Radius.

GetYAxis

GetYAxis() -> Vector3D

Get Y-Axis of the placement of the Ellipsoid

Returns:

GetYRadius

GetYRadius() -> float

Get Y Radius of the Ellipsoid

Returns:

  • float

    Reference to Y Radius.

GetZAxis

GetZAxis() -> Vector3D

Get Z - axis of the placement of the Ellipsoid

Returns:

GetZRadius

GetZRadius() -> float

Get Z Radius of the Ellipsoid

Returns:

  • float

    Reference to Z Radius.

IsSphere

IsSphere() -> bool

Test whether the Ellipsoid is Sphere

Returns:

  • bool

    true/false

IsValid

IsValid() -> bool

Validity check of the Ellipsoid

Returns:

  • bool

    true/false

SetCenter

SetCenter(center: Point3D)

Set center

Parameters:

SetLocalPlacement overloaded

SetLocalPlacement(placement: AxisPlacement3D)

Set Local Placement.

Parameters:

SetLocalPlacement(center: Point3D, xAxis: Vector3D, zAxis: Vector3D)

Set Local Placement.

Parameters:

  • center (Point3D) –

    Center point of the placement

  • xAxis (Vector3D) –

    X-axis of the placement

  • zAxis (Vector3D) –

    Z-axis of the placement

SetXRadius

SetXRadius(rad: float)

Set X Radius of the Ellipsoid

Parameters:

  • rad (float) –

    New radius.

Returns:

  • Reference to X Radius.

SetYRadius

SetYRadius(rad: float)

Set Y Radius of the Ellipsoid

Parameters:

  • rad (float) –

    New radius

SetZRadius

SetZRadius(rad: float)

Set Z Radius of the Ellipsoid

Parameters:

  • rad (float) –

    New radius

__eq__

__eq__(ellipsoid: Ellipsoid3D) -> object

Comparison of ellipsoids without tolerance.

Be careful, this method work without tolerance!

Parameters:

Returns:

  • object

    True when ellipsoids are equal, otherwise false.

__init__ overloaded

__init__()

Initialize

__init__(ellipsoid: Ellipsoid3D)

Copy constructor.

Parameters:

  • ellipsoid (Ellipsoid3D) –

    Ellipsoid which will be copied.

__init__(
    refPlacement: AxisPlacement3D,
    radiusX: float,
    radiusY: float,
    radiusZ: float,
)

Constructor.

Parameters:

  • refPlacement (AxisPlacement3D) –

    Local Placement of the ellipsoid.

  • radiusX (float) –

    X radius of the Ellipsoid.

  • radiusY (float) –

    Y radius of the Ellipsoid.

  • radiusZ (float) –

    Z radius of the Ellipsoid.

__init__(radiusX: float, radiusY: float, radiusZ: float)

Constructor.

Parameters:

  • radiusX (float) –

    X radius of the Ellipsoid.

  • radiusY (float) –

    Y radius of the Ellipsoid.

  • radiusZ (float) –

    Z radius of the Ellipsoid.

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string