Skip to content

GeometryExpansionUtil

Canonical path: NemAll_Python_Reinforcement.GeometryExpansionUtil

Methods:

  • GetLineAbove

    Get the line above the base line and the placement point

  • GetLineAtPoint

    Get the line at the defined point of the reference line

  • GetLineFromPoint

    Get the line near to the input point

  • GetLineLeft

    Get the line left from the base line and the placement point

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

GetLineAbove

GetLineAbove(arg2: Point2D, arg3: Line2D, arg4: bool, arg5: int) -> tuple

Get the line above the base line and the placement point

GetLineAtPoint

GetLineAtPoint(arg2: Point2D, arg3: Vector2D, arg4: bool, arg5: float) -> tuple

Get the line at the defined point of the reference line

GetLineFromPoint

GetLineFromPoint(
    arg2: DocumentAdapter, arg3: Point2D, arg4: ViewWorldProjection, arg5: bool
) -> tuple

Get the line near to the input point

GetLineLeft

GetLineLeft(arg2: Point2D, arg3: Line2D, arg4: bool, arg5: int) -> tuple

Get the line left from the base line and the placement point

__init__ overloaded

__init__()

Initialize

__init__(pMsgInfo: AddMsgInfo, use3DGeometry: bool)

Constructor

Parameters:

  • pMsgInfo (AddMsgInfo) –

    Additional message info

  • use3DGeometry (bool) –

    Use the 3D geometry for the expansione: true/false