Skip to content

ARGB

Canonical path: NemAll_Python_BasisElements.ARGB

Represents true color with transparency

Methods:

  • GetARGB

    returns color as unsigned long

  • __eq__

    equal operator

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert to string

Attributes:

  • ABGR (int) –

    returns color as ABGR

  • ARGB (int) –

    returns color as unsigned long

  • Alpha (int) –

    returns alpha component

  • BGR (int) –

    returns color as BGR

  • Blue (int) –

    returns blue component

  • Green (int) –

    returns green component

  • IRGB (int) –

    Get the indexed rgb color representation of the ARGB color

  • Red (int) –

    returns red component

ABGR property writable

ABGR: int

returns color as ABGR

sets color from unsigned long ABGR value

ARGB property writable

ARGB: int

returns color as unsigned long

sets color from ARGB

Alpha property writable

Alpha: int

returns alpha component

BGR property writable

BGR: int

returns color as BGR

sets only RGB values from unsigned long BGR format

Blue property writable

Blue: int

returns blue component

Green property writable

Green: int

returns green component

IRGB property writable

IRGB: int

Get the indexed rgb color representation of the ARGB color

If color not found in the index table, the rgb color converted to integer value is returned

Red property writable

Red: int

returns red component

GetARGB

GetARGB() -> int

returns color as unsigned long

Returns:

  • int

    color as long

__eq__

__eq__(argb: ARGB) -> bool

equal operator

Parameters:

  • argb (ARGB) –

    color to compare

Returns:

  • bool

    true if they are equal

__init__ overloaded

__init__()

Initialize

__init__(argb: int)

constructor from unsigned long

Parameters:

  • argb (int) –

    windows argb value

__init__(red: int, green: int, blue: int, alpha: int)

constructor with RGBA components

Parameters:

  • red (int) –

    red component

  • green (int) –

    green component

  • blue (int) –

    blue component

  • alpha (int) –

    alpha component

__init__(argb: ARGB)

copy constructor

Parameters:

  • argb (ARGB) –

    copy from

__repr__

__repr__() -> str

Convert to string