Skip to content

WallProperties

Canonical path: NemAll_Python_ArchElements.WallProperties

Representation of properties of a multi layer wall

Methods:

Attributes:

Axis property writable

Get the axis properties

PathElementAxisType property writable

PathElementAxisType: int

Get the axis type of the path element

StartNewJoinedWallGroup property writable

StartNewJoinedWallGroup: bool

Get the state for starting a new joined wall group

All walls in a group are used for to create a continues join between the walls.

TierCount property writable

TierCount: int

Get the tier count

GetAxis

GetAxis() -> AxisProperties

Get the axis properties

Returns:

GetPathElementAxisType

GetPathElementAxisType() -> int

Get the axis type of the path element

Returns:

  • int

    Axis type of the path element

GetThickness

GetThickness() -> float

Get the thickness

Returns:

  • float

    Thickness

GetTierCount

GetTierCount() -> int

Get the tier count

Returns:

  • int

    Tier count

GetWallTierProperties

GetWallTierProperties(tierIndex: int) -> WallTierProperties

Get the properties of a specified wall tier

Parameters:

  • tierIndex (int) –

    Tier index. First tier has the index 1!

Returns:

LoadFromFavoriteFile

LoadFromFavoriteFile(doc: DocumentAdapter)

Load the properties from the favorite file

Parameters:

SetAxis

SetAxis(axis: AxisProperties)

Set the axis

Parameters:

SetPathElementAxisType

SetPathElementAxisType(pathEleAxisType: int)

Set the axis type of the path element

Parameters:

  • pathEleAxisType (int) –

    Axis type of the path element

SetTierCount

SetTierCount(tierCount: int)

Set the tier count

Parameters:

  • tierCount (int) –

    Tier count

__init__ overloaded

__init__()

Initialize

__init__(wallProp: WallProperties)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string