Skip to content

BarAreaPlacementProperties

Canonical path: NemAll_Python_Reinforcement.BarAreaPlacementProperties

Classes:

Methods:

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

Benching

Canonical path: NemAll_Python_Reinforcement.BarAreaPlacementProperties.Benching

Bases: Enum

Benching type

Methods:

__getitem__

__getitem__(key: str | int | float) -> Benching

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

PlacementStrategy

Canonical path: NemAll_Python_Reinforcement.BarAreaPlacementProperties.PlacementStrategy

Bases: Enum

PlacementStrategy type

Methods:

__getitem__

__getitem__(key: str | int | float) -> PlacementStrategy

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

__init__ overloaded

__init__()

Initialize

__init__(
    diameter: float,
    distance: float,
    overlapping: float,
    isMoveOverlapping: bool,
    maxBarLength: float,
    startBarLength: float,
    maxPlacementLength: float,
    firstBarEdgeDistance: float,
    placementStrategy: PlacementStrategy,
    benching: Benching,
    benchingLength: float,
    isPolygonalPlacement: bool,
)

Constructor

Parameters:

  • diameter (float) –

    Diameter

  • distance (float) –

    Distance

  • overlapping (float) –

    Overlapping

  • isMoveOverlapping (bool) –

    Is overlapping moved: true/false

  • maxBarLength (float) –

    Maximal bar length

  • startBarLength (float) –

    Start bar length

  • maxPlacementLength (float) –

    Maximal placement length, 0 = will be calculated

  • firstBarEdgeDistance (float) –

    First bar edge distance, <0 = will be calculated

  • placementStrategy (PlacementStrategy) –

    Placement strategy

  • benching (Benching) –

    Benching

  • benchingLength (float) –

    Benching length

  • isPolygonalPlacement (bool) –

    Place in polygon: true / place per meter: false