Skip to content

SlabOpeningElement

Canonical path: NemAll_Python_ArchElements.SlabOpeningElement

Bases: ArchElement, AllplanElement

Implementation of the slab opening element

Methods:

Attributes:

PlacementPoint property writable

PlacementPoint: Point2D

Get the placement point

Properties property writable

Get the slab opening properties

GetPlacementPoint

GetPlacementPoint() -> Point2D

Get the placement point

Returns:

GetProperties

GetProperties() -> SlabOpeningProperties

Get the slab opening properties

Returns:

SetCommonProperties

SetCommonProperties(commonProp: CommonProperties)

Set the common properties

Parameters:

SetPlacementPoint

SetPlacementPoint(placementPoint: Point2D)

Set the placement point

Parameters:

  • placementPoint (Point2D) –

    Placement point

SetProperties

SetProperties(slabOpeningProp: SlabOpeningProperties)

Set the SlabOpening properties

Parameters:

__init__ overloaded

__init__()

Initialize

__init__(
    slabOpeningProp: SlabOpeningProperties,
    placementPoint: Point3D,
    slabConnectionUUID: GUID,
)

Constructor

Parameters:

  • slabOpeningProp (SlabOpeningProperties) –

    SlabOpening properties

  • placementPoint (Point3D) –

    Placement point

  • slabConnectionUUID (GUID) –

    Connection UUID of the slab

__init__(
    slabOpeningProp: SlabOpeningProperties,
    placementPoint: Point2D,
    slabConnectionUUID: GUID,
)

Constructor

Parameters:

  • slabOpeningProp (SlabOpeningProperties) –

    SlabOpening properties

  • placementPoint (Point2D) –

    Placement point

  • slabConnectionUUID (GUID) –

    Connection UUID of the slab

__init__(element: SlabOpeningElement)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string