Skip to content

ConsiderType

Canonical path: NemAll_Python_BasisElements.ConsiderType

Bases: Enum

Possible options for how a smart symbol (macro) placed in a room with finishing surfaces is displayed in animation and in sections

Attributes:

eConsiderAutomatic class-attribute instance-attribute

eConsiderAutomatic = 3

Automatic to nearest (floor or ceiling) surface - !!! don't use this value at the moment, it's only for internal usage

eConsiderCeilingOpening class-attribute instance-attribute

eConsiderCeilingOpening = 8

Adapts to ceiling opening

eConsiderCeilingRecess class-attribute instance-attribute

eConsiderCeilingRecess = 9

Adapts to ceiling recess

eConsiderCeilingSurface class-attribute instance-attribute

eConsiderCeilingSurface = 2

Adapts to the height of the ceiling in animation and sections.

eConsiderDoorOpening class-attribute instance-attribute

eConsiderDoorOpening = 5

Adapts to door opening

eConsiderFloorSurface class-attribute instance-attribute

eConsiderFloorSurface = 1

Adapts to the height of the floor

eConsiderNiche class-attribute instance-attribute

eConsiderNiche = 6

Adapts to niche opening

eConsiderNothing class-attribute instance-attribute

eConsiderNothing = 0

No adaptation

eConsiderRecess class-attribute instance-attribute

eConsiderRecess = 7

Adapts to recess opening

eConsiderWindowOpening class-attribute instance-attribute

eConsiderWindowOpening = 4

Adapts to window opening