Skip to content

EndSymbolsProperties

Canonical path: NemAll_Python_BasisElements.EndSymbolsProperties

Properties of start an end symbols of a ModelElement2D (line, polyline, etc...)

Methods:

  • __eq__

    equal operator

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert the list to a string

Attributes:

  • EndID (None) –

    Property for end symbol ID

  • EndSize (None) –

    Property for end symbol size

  • StartID (None) –

    Property for start symbol ID

  • StartSize (None) –

    Property for start symbol size

EndID property

EndID: None

Property for end symbol ID

:type: None

EndSize property

EndSize: None

Property for end symbol size

:type: None

StartID property

StartID: None

Property for start symbol ID

:type: None

StartSize property

StartSize: None

Property for start symbol size

:type: None

__eq__

__eq__(prop: EndSymbolsProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__ overloaded

__init__()

Initialize

__init__(startID: int, startSize: float, endID: int, endSize: float)

Constructor

Parameters:

  • startID (int) –

    ID of the start symbol

  • startSize (float) –

    Size of the start symbol

  • endID (int) –

    ID of the end symbol

  • endSize (float) –

    Size of the end symbol

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string