Skip to content

eValueInputControlType

Canonical path: NemAll_Python_IFW_Input.eValueInputControlType

Bases: Enum

Types of the input controls, that can be displayed in the dialog line in Allplan

Attributes:

  • eANGLE_COMBOBOX

    Angle input as a combo box with suggested angle values. Free input is possible.

  • eANGLE_EDIT

    Angle input as a regular edit field. Value is entered in the current Allplan angle units, but returned in radians.

  • eCONTROL_EXTERNAL
  • eCONTROL_NONE

    No input control

  • eCOORDINATE_EDIT

    Input control for a single coordinate. Value is entered in the current Allplan length units, but returned in millimeters. Allowed values between -1e10 and 1-e10

  • eCOORDINATE_EDIT_FIX

    Similar to eCOORDINATE_EDIT

  • eCOORDINATE_EDIT_GE0

    Similar to eCOORDINATE_EDIT, but only values >= 0 allowed

  • eCOORDINATE_EDIT_GT0

    Similar to eCOORDINATE_EDIT, but only values > 0 allowed

  • eDIMENSION_EDIT

    Length input with current length units. Returned value is in millimeters. Values between 0.0 and 1e10 allowed

  • eDIMENSION_EDIT_MM

    Length input in millimeters. Values between 0.0 and 1e10 allowed

  • eDOUBLE_EDIT

    Input control for a double value. Values between 0.0 and 1e10 allowed

  • eINT_COMBOBOX

    Similar to eINT_EDIT, but with a combo box with suggested values.

  • eINT_EDIT

    Input control for a 32-bit signed integer, with allowed value between 0 and -2147483684

  • eNUMBER_EDIT_1

    Edit control for an integer value between 1 and 1e6

  • eNUMBER_EDIT_1_GE0

    Edit control for an integer value between 0 and 1e6

  • eROTATION_ANGLE_STEP

    Input control for a shortcut input (+ or -). Input triggers the on_shortcut_control_input event.

  • eTEXT_EDIT

    String input control

  • eWALL_PLACEMENT

    Input control for a shortcut input (+ or -). Input triggers the on_shortcut_control_input event.

eANGLE_COMBOBOX class-attribute instance-attribute

eANGLE_COMBOBOX = 6

Angle input as a combo box with suggested angle values. Free input is possible.

eANGLE_EDIT class-attribute instance-attribute

eANGLE_EDIT = 11

Angle input as a regular edit field. Value is entered in the current Allplan angle units, but returned in radians.

eCONTROL_EXTERNAL class-attribute instance-attribute

eCONTROL_EXTERNAL = 1

eCONTROL_NONE class-attribute instance-attribute

eCONTROL_NONE = 0

No input control

eCOORDINATE_EDIT class-attribute instance-attribute

eCOORDINATE_EDIT = 101

Input control for a single coordinate. Value is entered in the current Allplan length units, but returned in millimeters. Allowed values between -1e10 and 1-e10

eCOORDINATE_EDIT_FIX class-attribute instance-attribute

eCOORDINATE_EDIT_FIX = 102

Similar to eCOORDINATE_EDIT

eCOORDINATE_EDIT_GE0 class-attribute instance-attribute

eCOORDINATE_EDIT_GE0 = 103

Similar to eCOORDINATE_EDIT, but only values >= 0 allowed

eCOORDINATE_EDIT_GT0 class-attribute instance-attribute

eCOORDINATE_EDIT_GT0 = 104

Similar to eCOORDINATE_EDIT, but only values > 0 allowed

eDIMENSION_EDIT class-attribute instance-attribute

eDIMENSION_EDIT = 5

Length input with current length units. Returned value is in millimeters. Values between 0.0 and 1e10 allowed

eDIMENSION_EDIT_MM class-attribute instance-attribute

eDIMENSION_EDIT_MM = 10

Length input in millimeters. Values between 0.0 and 1e10 allowed

eDOUBLE_EDIT class-attribute instance-attribute

eDOUBLE_EDIT = 2

Input control for a double value. Values between 0.0 and 1e10 allowed

eINT_COMBOBOX class-attribute instance-attribute

eINT_COMBOBOX = 4

Similar to eINT_EDIT, but with a combo box with suggested values.

eINT_EDIT class-attribute instance-attribute

eINT_EDIT = 3

Input control for a 32-bit signed integer, with allowed value between 0 and -2147483684

eNUMBER_EDIT_1 class-attribute instance-attribute

eNUMBER_EDIT_1 = 201

Edit control for an integer value between 1 and 1e6

eNUMBER_EDIT_1_GE0 class-attribute instance-attribute

eNUMBER_EDIT_1_GE0 = 202

Edit control for an integer value between 0 and 1e6

eROTATION_ANGLE_STEP class-attribute instance-attribute

eROTATION_ANGLE_STEP = 8

Input control for a shortcut input (+ or -). Input triggers the on_shortcut_control_input event.

eTEXT_EDIT class-attribute instance-attribute

eTEXT_EDIT = 9

String input control

eWALL_PLACEMENT class-attribute instance-attribute

eWALL_PLACEMENT = 7

Input control for a shortcut input (+ or -). Input triggers the on_shortcut_control_input event.