Skip to content

PreviewSymbolBuilder

Canonical path: NemAll_Python_IFW_Input.PreviewSymbolBuilder

Implementation of the preview symbol builder

Methods:

ArrowSymbol overloaded

ArrowSymbol(
    pnt: Point3D,
    bDrawIso: bool,
    viewProj: ViewWorldProjection,
    colorVariant: ARGB,
    widthVariant: int,
    rotationAngle: float,
    allWindows: bool = True,
)

Create an arrow symbol

Parameters:

  • pnt (Point3D) –

    Arrowhead point

  • bDrawIso (bool) –

    Draw the arrow symbol inside the isometric view: true/false

  • viewProj (ViewWorldProjection) –

    View world projection data

  • colorVariant (ARGB) –

    Color of the preview

  • widthVariant (int) –

    Width of the symbol

  • rotationAngle (float) –

    Rotation angle of the rectangle

  • allWindows (bool, default: True ) –

    Show symbol in all windows

ArrowSymbol(
    pnt: Point3D,
    bDrawIso: bool,
    viewProj: ViewWorldProjection,
    colorVariant: ARGB,
    rotationAngle: float,
    allWindows: bool = True,
)

Create a small arrow symbol

Parameters:

  • pnt (Point3D) –

    Arrowhead point

  • bDrawIso (bool) –

    Draw the arrow symbol inside the isometric view: true/false

  • viewProj (ViewWorldProjection) –

    View world projection data

  • colorVariant (ARGB) –

    Color of the preview

  • rotationAngle (float) –

    Rotation angle of the rectangle

  • allWindows (bool, default: True ) –

    Show symbol in all windows

Circle3DSymbol staticmethod

Circle3DSymbol(
    refPnt: Point3D,
    circle: Arc3D,
    viewProj: ViewWorldProjection,
    colorVariant: ARGB,
    linePattern: int,
    lineWidth: float,
)

Create a 3D circle symbol preview

Parameters:

  • refPnt (Point3D) –

    Reference point

  • circle (Arc3D) –

    3D circle

  • viewProj (ViewWorldProjection) –

    View world projection data

  • colorVariant (ARGB) –

    Color of the preview

  • linePattern (int) –

    Line pattern

  • lineWidth (float) –

    Width of the line

CircleSymbol staticmethod

CircleSymbol(
    pnt: Point3D,
    bDrawIso: bool,
    viewProj: ViewWorldProjection,
    colorVariant: ARGB,
    radius: int,
)

Create a circle symbol

Parameters:

  • pnt (Point3D) –

    Center point

  • bDrawIso (bool) –

    Draw the circle symbol inside the isometric view: true/false

  • viewProj (ViewWorldProjection) –

    View world projection data

  • colorVariant (ARGB) –

    Color of the preview

  • radius (int) –

    Radius of the circle in pixel

CoordCrossSymbol overloaded

CoordCrossSymbol(plane: Plane3D, armLength: int, viewProj: ViewWorldProjection)

Draw the coordinate cross symbol

Parameters:

  • plane (Plane3D) –

    Plane

  • armLength (int) –

    Length of the symbol arms

  • viewProj (ViewWorldProjection) –

    View world projection

CoordCrossSymbol(
    axisPlacement: AxisPlacement3D,
    armLength: int,
    viewProj: ViewWorldProjection,
)

Draw the coordinate cross symbol

Parameters:

CrossSymbol staticmethod

CrossSymbol(
    pnt: Point3D,
    bDrawIso: bool,
    viewProj: ViewWorldProjection,
    colorVariant: ARGB,
    widthVariant: int,
)

Create a cross symbol

Parameters:

  • pnt (Point3D) –

    Cross center point

  • bDrawIso (bool) –

    Draw the cross symbol inside the isometric view: true/false

  • viewProj (ViewWorldProjection) –

    View world projection data

  • colorVariant (ARGB) –

    Color of the preview

  • widthVariant (int) –

    Width of the symbol

FilledRectangleSymbol staticmethod

FilledRectangleSymbol(
    pnt: Point3D,
    bDrawIso: bool,
    viewProj: ViewWorldProjection,
    colorVariant: ARGB,
    widthVariant: int,
    rotationAngle: float,
)

Create a filled rectangle symbol

Parameters:

  • pnt (Point3D) –

    Rectangle center point

  • bDrawIso (bool) –

    Draw the rectangle symbol inside the isometric view: true/false

  • viewProj (ViewWorldProjection) –

    View world projection data

  • colorVariant (ARGB) –

    Color of the preview

  • widthVariant (int) –

    Width of the symbol

  • rotationAngle (float) –

    Rotation angle of the rectangle

Line3DSymbol staticmethod

Line3DSymbol(
    refPnt: Point3D,
    line: Line3D,
    viewProj: ViewWorldProjection,
    colorVariant: ARGB,
    linePattern: int,
    lineWidth: int,
)

Create a 3D line symbol preview

Parameters:

  • refPnt (Point3D) –

    Reference point

  • line (Line3D) –

    3D line

  • viewProj (ViewWorldProjection) –

    View world projection data

  • colorVariant (ARGB) –

    Color of the preview

  • linePattern (int) –

    Line pattern

  • lineWidth (int) –

    Line width

LocalCoordinateSystem staticmethod

LocalCoordinateSystem(
    coordSystemMatrix: Matrix3D, flags: LCS_Flags, maxSize: float
)

Create a symbol for a local coordinate system

Parameters:

  • coordSystemMatrix (Matrix3D) –

    Matrix of the coordinate system

  • flags (LCS_Flags) –

    Coordinate system flags

  • maxSize (float) –

    Max size of the coordinate system

MarkSymbol staticmethod

MarkSymbol(
    pnt: Point3D,
    bDrawIso: bool,
    viewProj: ViewWorldProjection,
    colorVariant: ARGB,
    widthVariant: int,
)

Create a mark symbol (drawn an x)

Parameters:

  • pnt (Point3D) –

    Mark center point

  • bDrawIso (bool) –

    Draw the mark symbol inside the isometric view: true/false

  • viewProj (ViewWorldProjection) –

    View world projection data

  • colorVariant (ARGB) –

    Color of the preview

  • widthVariant (int) –

    Width of the symbol

OffsetPointSymbols staticmethod

OffsetPointSymbols(
    refPnt: Point3D,
    offPnt: Point3D,
    bDrawIso: bool,
    viewProj: ViewWorldProjection,
    colorVariant: ARGB,
    widthVariant: int,
    refPntAngle: float,
    offPntAngle: float,
)

Create the symbols for an offset point

Parameters:

  • refPnt (Point3D) –

    Reference point

  • offPnt (Point3D) –

    Offset point

  • bDrawIso (bool) –

    Draw the arrow symbol inside the isometric view: true/false

  • viewProj (ViewWorldProjection) –

    View world projection data

  • colorVariant (ARGB) –

    Color of the preview

  • widthVariant (int) –

    Width of the symbol

  • refPntAngle (float) –

    Angle at the reference point

  • offPntAngle (float) –

    Angle at the offset point

OrthogonalSymbol staticmethod

OrthogonalSymbol(
    pnt: Point3D,
    bDrawIso: bool,
    viewProj: ViewWorldProjection,
    colorVariant: ARGB,
    widthVariant: int,
)

Create an orthogonal symbol

Parameters:

  • pnt (Point3D) –

    Center point

  • bDrawIso (bool) –

    Draw the circle symbol inside the isometric view: true/false

  • viewProj (ViewWorldProjection) –

    View world projection data

  • colorVariant (ARGB) –

    Color of the preview

  • widthVariant (int) –

    Width of the symbol

ParallelSymbol staticmethod

ParallelSymbol(
    pnt: Point3D,
    bDrawIso: bool,
    viewProj: ViewWorldProjection,
    colorVariant: ARGB,
    widthVariant: int,
)

Create a parallel symbol

Parameters:

  • pnt (Point3D) –

    Center point

  • bDrawIso (bool) –

    Draw the circle symbol inside the isometric view: true/false

  • viewProj (ViewWorldProjection) –

    View world projection data

  • colorVariant (ARGB) –

    Color of the preview

  • widthVariant (int) –

    Width of the symbol

Polyline2DSymbol staticmethod

Polyline2DSymbol(
    refPnt: Point3D,
    polyline: Polyline2D,
    viewProj: ViewWorldProjection,
    colorVariant: ARGB,
    linePattern: int,
)

Create a 2D polyline symbol preview

Parameters:

  • refPnt (Point3D) –

    Reference point

  • polyline (Polyline2D) –

    Polyline

  • viewProj (ViewWorldProjection) –

    View world projection

  • colorVariant (ARGB) –

    Color of the preview

  • linePattern (int) –

    Line pattern

Polyline3DSymbol overloaded

Polyline3DSymbol(
    polyline: Polyline3D,
    viewProj: ViewWorldProjection,
    colorVariant: ARGB,
    linePattern: int,
)

Create a 3D polyline symbol preview

Parameters:

  • polyline (Polyline3D) –

    3D Polyline

  • viewProj (ViewWorldProjection) –

    View world projection data

  • colorVariant (ARGB) –

    Color of the preview

  • linePattern (int) –

    Line pattern

Polyline3DSymbol(
    refPnt: Point3D,
    polyline: Polyline3D,
    viewProj: ViewWorldProjection,
    colorVariant: ARGB,
    linePattern: int,
)

Create a 3D polyline symbol preview

Parameters:

  • refPnt (Point3D) –

    Reference point

  • polyline (Polyline3D) –

    Polyline

  • viewProj (ViewWorldProjection) –

    View world projection

  • colorVariant (ARGB) –

    Color of the preview

  • linePattern (int) –

    Line pattern

TrackLine staticmethod

TrackLine(
    line: Line3D,
    bDrawIso: bool,
    viewProj: ViewWorldProjection,
    colorVariant: ARGB,
    trackLineType: eTrackLineType,
)

Create a track line

Parameters:

  • line (Line3D) –

    Track line

  • bDrawIso (bool) –

    Draw the circle symbol inside the isometric view: true/false

  • viewProj (ViewWorldProjection) –

    View world projection data

  • colorVariant (ARGB) –

    Color of the preview

  • trackLineType (eTrackLineType) –

    Type of the track line

TrackMarkSymbol staticmethod

TrackMarkSymbol(
    pnt: Point3D,
    bDrawIso: bool,
    viewProj: ViewWorldProjection,
    colorVariant: ARGB,
    widthVariant: int,
)

Create a track mark symbol

Parameters:

  • pnt (Point3D) –

    Center point

  • bDrawIso (bool) –

    Draw the circle symbol inside the isometric view: true/false

  • viewProj (ViewWorldProjection) –

    View world projection data

  • colorVariant (ARGB) –

    Color of the preview

  • widthVariant (int) –

    Width of the symbol