Skip to content

IntersectRayPolyhedronFlag

Canonical path: NemAll_Python_Geometry.IntersectRayPolyhedronFlag

Bases: Enum

Flag for determining the best result of ray-polyhedron intersection

ePositiveOnly allow only intersections with lambda >= 0 prefer the smallest one eNegativeIfNoPositive : allow negative intersections, but only if not positive intersection can be found prefer intersections with lambda close to 0 (i.e., prefer -1 over -2) eNegativePreferred : search for the intersection with the smallest lambda prefer negative over positive, prefer -2 over -1 (this is a simple linear comparison) eSmallestLmabda : search for the intersection with the smallest lambda eNegativeVerticalPreferred: search for the intersection with vertical faces which are perpendicular to ground plan

Attributes:

eNegativeIfNoPositive class-attribute instance-attribute

eNegativeIfNoPositive = 1

eNegativePreferred class-attribute instance-attribute

eNegativePreferred = 2

eNegativeVerticalPreferred class-attribute instance-attribute

eNegativeVerticalPreferred = 4

ePositiveOnly class-attribute instance-attribute

ePositiveOnly = 0

eSmallestLmabda class-attribute instance-attribute

eSmallestLmabda = 3