Skip to content

ReinforcementShapeBuilder

Canonical path: NemAll_Python_Reinforcement.ReinforcementShapeBuilder

Implementation of the reinforcement shape builder

Methods:

AddPoint overloaded

AddPoint(
    pnt: Point2D,
    concreteCover: float,
    bendingRoller: float,
    zCoordBar: float = 0,
)

Add an end point of a geometry side

Parameters:

  • pnt (Point2D) –

    End point of the side

  • concreteCover (float) –

    Concrete cover

  • bendingRoller (float) –

    Bending roller

  • zCoordBar (float, default: 0 ) –

    Bar coordinate in z direction of the local shape coordinate system

AddPoint(pnt: Point3D, concreteCover: float, bendingRoller: float)

Add an end point of a geometry side

Parameters:

  • pnt (Point3D) –

    End point of the side

  • concreteCover (float) –

    Concrete cover

  • bendingRoller (float) –

    Bending roller

AddPoints

AddPoints(pointList: object)

Add the shape geometry points

Parameters:

  • pointList (object) –

    Point list

AddSide overloaded

AddSide(
    startPnt: Point2D,
    endPnt: Point2D,
    concreteCover: float,
    bendingRoller: float,
    zCoordBar: float = 0,
)

Add a geometry side of the shape

Parameters:

  • startPnt (Point2D) –

    Start point of the geometry side

  • endPnt (Point2D) –

    End point of the geometry side

  • concreteCover (float) –

    Concrete cover

  • bendingRoller (float) –

    Bending roller between the last and current side

  • zCoordBar (float, default: 0 ) –

    Bar coordinate in z direction of the local shape coordinate system

AddSide(
    startPnt: Point3D,
    endPnt: Point3D,
    concreteCover: float,
    bendingRoller: float,
)

Add a geometry side of the shape

Parameters:

  • startPnt (Point3D) –

    Start point of the geometry side

  • endPnt (Point3D) –

    End point of the geometry side

  • concreteCover (float) –

    Concrete cover

  • bendingRoller (float) –

    Bending roller between the last and current side

AddSides

AddSides(sideList: object)

Add the geometry sides of a shape

Parameters:

  • sideList (object) –

    Side list

CreateShape overloaded

CreateShape(
    diameter: float,
    bendingRoller: float,
    steelGrade: int,
    concreteGrade: int,
    bendingShapeType: BendingShapeType,
) -> BendingShape

Create the shape

Parameters:

  • diameter (float) –

    Diameter

  • bendingRoller (float) –

    Default bending roller

  • steelGrade (int) –

    Steel grade

  • concreteGrade (int) –

    Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)

  • bendingShapeType (BendingShapeType) –

    Bending shape type

Returns:

CreateShape(
    meshType: str,
    meshBendingDirection: MeshBendingDirection,
    bendingRoller: float,
    steelGrade: int,
    concreteGrade: int,
    bendingShapeType: BendingShapeType,
) -> BendingShape

Create the shape

Parameters:

  • meshType (str) –

    Mesh type

  • meshBendingDirection (MeshBendingDirection) –

    Mesh bending direction

  • bendingRoller (float) –

    Default bending roller

  • steelGrade (int) –

    Steel grade

  • concreteGrade (int) –

    Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)

  • bendingShapeType (BendingShapeType) –

    Bending shape type

Returns:

CreateShape(shapeProps: object) -> BendingShape

Create the shape

Parameters:

  • shapeProps (object) –

    Shape properties

Returns:

CreateStirrup overloaded

CreateStirrup(
    diameter: float,
    bendingRoller: float,
    steelGrade: int,
    concreteGrade: int,
    stirrupType: StirrupType,
) -> BendingShape

Create the stirrup shape

Parameters:

  • diameter (float) –

    Diameter

  • bendingRoller (float) –

    Default bending roller

  • steelGrade (int) –

    Steel grade

  • concreteGrade (int) –

    Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)

  • stirrupType (StirrupType) –

    Type of the stirrup

Returns:

CreateStirrup(
    meshType: str,
    meshBendingDirection: MeshBendingDirection,
    bendingRoller: float,
    steelGrade: int,
    concreteGrade: int,
    stirrupType: StirrupType,
) -> BendingShape

Create the stirrup shape

Parameters:

  • meshType (str) –

    Mesh type

  • meshBendingDirection (MeshBendingDirection) –

    Mesh bending direction

  • bendingRoller (float) –

    Default bending roller

  • steelGrade (int) –

    Steel grade

  • concreteGrade (int) –

    Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)

  • stirrupType (StirrupType) –

    Type of the stirrup

Returns:

CreateStirrup(shapeProps: object, stirrupType: StirrupType) -> BendingShape

Create the stirrup shape

Parameters:

  • shapeProps (object) –

    Shape properties

  • stirrupType (StirrupType) –

    Type of the stirrup

Returns:

GetMeshData staticmethod

GetMeshData(meshType: str) -> MeshData

Get the mesh data

Parameters:

  • meshType (str) –

    Mesh type

Returns:

SetAnchorageHookEnd

SetAnchorageHookEnd(angle: float)

Set an anchorage hook at the end of the shape

Parameters:

  • angle (float) –

    Hook angle

SetAnchorageHookEndFromSide

SetAnchorageHookEndFromSide()

Set an anchorage hook at the end of the shape, get the angle from the side

SetAnchorageHookStart

SetAnchorageHookStart(angle: float)

Set an anchorage hook at the start of the shape

Parameters:

  • angle (float) –

    Hook angle

SetAnchorageHookStartFromSide

SetAnchorageHookStartFromSide()

Set an anchorage hook at the start of the shape, get the angle from the side

SetAnchorageLengthEnd

SetAnchorageLengthEnd(anchorageLength: float)

Set the anchorage length at the end of the shape

Parameters:

  • anchorageLength (float) –

    Anchorage length at the end of the shape

SetAnchorageLengthStart

SetAnchorageLengthStart(anchorageLength: float)

Set the anchorage length at the start of the shape

Parameters:

  • anchorageLength (float) –

    Anchorage length at the start of the shape

SetConcreteCoverEnd

SetConcreteCoverEnd(concreteCover: float)

Set the concrete cover at the end of the shape

Parameters:

  • concreteCover (float) –

    Concrete cover

SetConcreteCoverLineEnd overloaded

SetConcreteCoverLineEnd(
    startPnt: Point2D, endPnt: Point2D, concreteCover: float
)

Set the concrete cover line at the end of the shape

Parameters:

  • startPnt (Point2D) –

    Start point of the concrete cover line at the end of the shape

  • endPnt (Point2D) –

    Endpoint of the concrete cover line at the end of the shape

  • concreteCover (float) –

    Concrete cover

SetConcreteCoverLineEnd(
    startPnt: Point3D, endPnt: Point3D, concreteCover: float
)

Set the concrete cover line at the end of the shape

Parameters:

  • startPnt (Point3D) –

    Start point of the concrete cover line at the end of the shape

  • endPnt (Point3D) –

    Endpoint of the concrete cover line at the end of the shape

  • concreteCover (float) –

    Concrete cover

SetConcreteCoverLineStart overloaded

SetConcreteCoverLineStart(
    startPnt: Point2D, endPnt: Point2D, concreteCover: float
)

Set the concrete cover line at the start of the shape

Parameters:

  • startPnt (Point2D) –

    Start point of the concrete cover line at the start of the shape

  • endPnt (Point2D) –

    Endpoint of the concrete cover line at the start of the shape

  • concreteCover (float) –

    Concrete cover

SetConcreteCoverLineStart(
    startPnt: Point3D, endPnt: Point3D, concreteCover: float
)

Set the concrete cover line at the start of the shape

Parameters:

  • startPnt (Point3D) –

    Start point of the concrete cover line at the start of the shape

  • endPnt (Point3D) –

    Endpoint of the concrete cover line at the start of the shape

  • concreteCover (float) –

    Concrete cover

SetConcreteCoverStart

SetConcreteCoverStart(concreteCover: float)

Set the concrete cover at the start of the shape

Parameters:

  • concreteCover (float) –

    Concrete cover

SetFullCircleOverlap

SetFullCircleOverlap(fullCircleOverlap: float)

Set the overlap length for the full circle stirrup

Parameters:

  • fullCircleOverlap (float) –

    Overlap length

SetHookEnd

SetHookEnd(length: float, angle: float, type: HookType)

Set the hook at the end of the shape

Parameters:

  • length (float) –

    Hook length (0 = calculate)

  • angle (float) –

    Hook angle

  • type (HookType) –

    Hook type

SetHookStart

SetHookStart(length: float, angle: float, type: HookType)

Set the hook at the start of the shape

Parameters:

  • length (float) –

    Hook length (0 = calculate)

  • angle (float) –

    Hook angle

  • type (HookType) –

    Hook type

SetOverlapLengthEnd

SetOverlapLengthEnd()

Set an overlap length a the end of the shape

SetOverlapLengthStart

SetOverlapLengthStart()

Set an overlap length a the start of the shape

SetSideLengthEnd

SetSideLengthEnd(sideLength: float)

Set the side length at the end of the shape

Parameters:

  • sideLength (float) –

    Side length

SetSideLengthStart

SetSideLengthStart(sideLength: float)

Set the side length at the start of the shape

Parameters:

  • sideLength (float) –

    Side length

SetStartPoint overloaded

SetStartPoint(startPnt: Point2D)

Set a start point of a geometry side

Parameters:

  • startPnt (Point2D) –

    Start point

SetStartPoint(startPnt: Point3D)

Set a start point of a geometry side

Parameters:

  • startPnt (Point3D) –

    Start point

__init__ overloaded

__init__()

Initialize

__init__(shapePlaneMatrix: Matrix3D)

Constructor

Parameters:

  • shapePlaneMatrix (Matrix3D) –

    Matrix of the plane for the real shape calculation

__init__(
    shapePlaneMatrix: Matrix3D,
    create3DShape: bool,
    localZCoverFront: float,
    localZCoverBack: float,
)

Constructor

Parameters:

  • shapePlaneMatrix (Matrix3D) –

    Matrix of the plane for the real shape calculation

  • create3DShape (bool) –

    Create a 3D shape

  • localZCoverFront (float) –

    Concrete cover in the front of the local z direction of the shape (needed for 3D shape)

  • localZCoverBack (float) –

    Concrete cover in the back of the local z direction of the shape (needed for 3D shape)

__init__(element: ReinforcementShapeBuilder)

Copy constructor

Parameters: